Closed Bug 556442 Opened 10 years ago Closed 9 years ago

v3, v3.1 Excruciatingly slow message read and switching, 10-15 seconds of 25% cpu until the selected message appears in the message preview, antivirus and firewall disabled

Categories

(Thunderbird :: Message Reader UI, defect, major)

x86
Windows 7
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 599119

People

(Reporter: pjcamp, Unassigned)

Details

(Keywords: perf, regression, Whiteboard: [recap: v2 works, gloda off, new profile])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.9) Gecko/20100317 Lightning/1.0b2pre Thunderbird/3.0.4

Select an email message and 15 - 30 seconds later, you will be able to read it. Change to another message and the selection will not change for another 15-30 seconds.

Reproducible: Always

Steps to Reproduce:
1. Start Thunderbird.
2. Try to read something.
Actual Results:  
As described above, slow. But this is only in the email list pane and the reader pane. The folders pane is as fast as ever.

Expected Results:  
Not be slow. Let me read email.

I have set my antivirus to ignore the mailbox. I have disabled my antivirus and firewall. I have run through every step in the general troubleshooter and the memory troubleshooter. I've created a new profile. I've started in safe mode. I've uninstalled the program, deleted the program folder, and reinstalled. Nothing affects the problem one iota.

There is one potential clue -- on the memory troubleshooter, it tells me to check the size of the sqlite database and if it is significantly larger than the mail folder, that may be troublesome. The db is about twice the size of the mail folder. I don't know if that counts as significantly larger, but in any case the memory troubleshooter directs me to a list of hints none of which apply to my system.

It was working fine until the most recent update. Since then it has been a dog. I'd change clients except most of the ones available are just something built on top of Thunderbird so what's the point?
Yes, if global-messages-db.sqlite is twice the size of the Mail and ImapMail folders, that's definitely "significantly larger" -- under ordinary usage, it rarely gets above 10% or 20% of the mail folders' size.

I suggest you delete that file (don't worry, it will be automatically re-created -- although things may go slowly for some time during the re-creation process).

However, first it'd be good to know exactly what happened when you created a new profile. Did it simply stay slow forever? How long have you tried running with that profile? In particular, I suspect that the slow performance after creating a new profile is due more to the initial message indexing than anything else, and should go away after not too long.

(CC:ing asuth, in case this turns out to be gloda-related. ;-))
Keywords: perf
(In reply to comment #1)
> Yes, if global-messages-db.sqlite is twice the size of the Mail and ImapMail
> folders, that's definitely "significantly larger" -- under ordinary usage, it
> rarely gets above 10% or 20% of the mail folders' size.

Quick correction: rarely above 50%, in my experience.
No such luck. DB was recreated but Thunderbird is still massively slow in those two panes.

I didn't run with the new profile for very long, but then it didn't have any messages to index. I created an essentially blank profile and sent a couple of test messages. So it had two messages called "test" whose content was "This is a test." That shouldn't take that long to index.
Does this happen with a brand new mostly empty profile? There are some known issues reading html mail with images in profiles with a lot of folders, but this sounds like it's all mail in profiles with very few folders.
(In reply to comment #0)
> Gecko/20100317 Lightning/1.0b2pre Thunderbird/3.0.4

> It was working fine until the most recent update.

Upgrade to Tb 3.0.4 from which version of Tb? From Tb 3.0.x? From Tb 2?
 
> Actual Results:  
> As described above, slow. But this is only in the email list pane and the
> reader pane. The folders pane is as fast as ever.

What kind of phenomenon do you mean by "slow in email list pane"?
What kind of phenomenon do you mean by "slow in reader pane"?

The slowness(it takes 15-30sec) is for time between "click a mail at email list pane" and "mail display at reader pane", isn't it?
Does "slow in email list pane" mean "selection will not change for another 15-30 seconds" at "email list pane"? i.e. "Higlighting of newly selected mail" is executed after 15-30 seconds" at "email list pane"?

Does the slowness(it takes 15-30sec) occur with what kind of mail folder? IMAP folder? Local mail folder(POP3, "Local Mal Folder")? Or both?

Performance bugs relates to HTML mail which David mentioned in comment #4 are bug 536873 and bug 545126. pjcamp(bug opener), you upgraded from Tb2 and the "slowness"(takes 15-30sec to display a mail) is these bugs? As you say "most recent upgarade", it sounds for me you are looking new problem with Tb 3.0.4 which didn't occur with Tb 3.0.0 to Tb 3.0.3...
David: Happens with every profile, as far as I can tell. One I've been using for years, the other I created yesterday. The one I created yesterday had the default set of folders. The one I use regularly has a few more but not a huge number. Almost all the mail is plain text.

WADA: I've upgraded pretty much every time there has been an upgrade available so it would have been from whatever the pushed version was prior to 3.0.3 probably.

Slow means I select a message by clicking on it with my mouse. Several seconds later, the message actually appears in the reader pane. Select the next message and again, several seconds will pass until the new message appears in the reader pane.

Now I suppose this could just be an issue with the one pane that displays the list of messages in my inbox since the reader pane probably can't display anything until the inbox pane has completed whatever it is up to.

The mail is POP3. It occurs in every folder within Local Folders.

There is one other potentially related issue, an upgrade from XP Pro 32 to Windows 7 64. I used PCMover to do that without having to reinstall hundreds of applications. But everything else seems to work smoothly, with the exception of a handful of drivers, and I would have thought any issues would have been dealt with by a clean reinstall of TB.
(In reply to comment #6)
> Now I suppose this could just be an issue with the one pane that displays the
> list of messages in my inbox since the reader pane probably can't display
> anything until the inbox pane has completed whatever it is up to.
> 
> The mail is POP3. It occurs in every folder within Local Folders.

Which view of folder pane do you use? "All Folders"? "Smart Folders"? Or other?
Is your problem reproduced with -safe-mode of Thunderbird? (start Tb with ...\thunderbird.exe -safe-mode)

> an upgrade from XP Pro 32 to Windows 7 64.

Which build do you use on MS Win7 64? 32bits verstion of Tb? 64bits version of Tb? (AFAIK, official 64bit version of Tb is not available yet...)  

> with the exception of a handful of drivers, (snip)

What do you mena by the "a handful of drivers"?
I use Smart Folders. I guess it is the default and I never changed it.

Safe mode has no effect. That was one of the first things I tried (see first post above).

If the 64 bit is not available, then I use 32 since I just download whatever is linked on the main TB web page. Not sure how I would tell, but I don't go out of my way to find it.

By "handful of drivers," I mean that I had to update by audio and flatbed scanner drivers to more recent versions. As far as I know, Thunderbird doesn't depend on either of those to function.
can we do something here to confirm or rule out bug 545126?
Well, if you have someone in Atlanta they can come to my house and watch it happen.
can confirm same sort of problem/symptoms.  on recommendation of the wiki article on Thunderbird:Testing:Memory Usage Problems I turned off Global Indexing and the results were successful.  Thunderbird returned to its generally blazing speeds - -in all folders of varied small to large sizes.
I turned off Global Indexing (and in fact am currently running with it off). This action had no impact on performance. Switching from one message to another is still slow as molasses.
Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.1.9) Gecko/20100317 Lightning/1.0b1 Thunderbird/3.0.4

Can confirm this in Vista64 (with big profile on NW share). Switching off indexing did not had any impact. The profile was taken from TB2.
> Comment 11 Chris Earle
>   can confirm same sort of problem/symptoms.
> Comment 13 Frank Freund
>   Can confirm this in Vista64 (with big profile on NW share).

To  pjcamp(bug opener), Chris Earle(Comment 11), and Frank Freund(Comment 13): 

(Q1) Have you read and understood all bugs pointed in this bug?
(Q2) If answer to (Q1) is yes, what is difference from problem of the already pointed bug(s)?

To Chris Earle(Comment 11) and Frank Freund(Comment 13): 

(Q3) What/which phenomenon/problem on what condition of this bug which is reported by bug opener do you confirm?
(Q4) If similar/same phenomenon on similar/same condition, what is your evidence that your problem is same problem as this bug stated by bug opener?
(In reply to comment #14)
> (Q1) Have you read and understood all bugs pointed in this bug?
Yes, but read them partially only - because I was not aware that it's a HTML related issue. Read them now completely - and what turns out?
For me bug 545126 seems to be the one. As it's resolved and in TB31b2, I tested it and it works as expected (even if Lightning does not:-( ). Last time I tried Lanikai b1 and it did not improved, which matches the timeline of bug 545126.
So thanks for the hint WADA.

> (Q3) What/which phenomenon/problem on what condition of this bug which is
> reported by bug opener do you confirm?
Maybe I should have been more clear here, so it should have been: "I can confirm the issue as described by the bug opener":
>> Select an email message and 15 - 30 seconds later, you will be able 
>> to read it. Change to another message and the selection will not 
>> change for another 15-30 seconds. But this is only in the email 
>> list pane and the reader pane. 
>> The folders pane is as fast as ever.

> (Q4) If similar/same phenomenon on similar/same condition, what is your
> evidence that your problem is same problem as this bug stated by bug opener?
see answer to Q3(?)
WADA:

Yes, I have read everything available on this bug. I spent the better part of two weeks searching the Mozilla knowledge bases and more generally on Google for information on this problem.

The major difference is that nothing from any of the troubleshooters (please read prior posts for an incomplete summary of things I have tried) has any effect whatsoever on the performance deficit. If none of the previously devises fixes and workarounds work, the likelihood is that it is a new issue.
Moved to TB 3.1. No effect. Still major slow. Checked mailbox exclusions in Norton Internet Security and added the entire TB Application Data folder to the exclusions. No effect. Watched running processes using the What's Running tool. If I select a message to read, TB usage jumps to 25% of CPU cycles for 10-15 seconds, until the selected message appears in the read window. The Norton services stay at 0, which I interpret as evidence that the exclusion is working.

I'm going to revert to TB2 and see what happens.
pjcamp, thanks for the added testing. Sorry we're not finding the cause of your problem yet.

Do you also see the high cpu switching messages if the message preview pane is closed?  F8 or View | Layout | Message Pane

And, when you used a new profile, did you leave the address book empty?
Component: Folder and Message Lists → Message Reader UI
QA Contact: folders-message-lists → message-reader
Summary: SLOW! Excruciatingly slow message read and switching → v3, v3.1 Excruciatingly slow message read and switching, 10-15 seconds of 25% cpu until the selected message appears in the message preview
Whiteboard: [recap: v2 works, gloda off, new profile]
Version: unspecified → 3.1
Yes to both of those questions.

In addition, I reverted to TB2 (just finished). It switches between messages instantly and What's Running reports that it uses 1.8% cpu cycles while doing so.

So this appears to be an issue with 3.x specifically, or possibly with regard to in place upgrades from 2.x to 3.x.
pjcamp in comment 0 you state testing with firewall disabled. What firewall SW do you use?  Can you test with thunderbird set to offline mode using version 3.1.2?
Summary: v3, v3.1 Excruciatingly slow message read and switching, 10-15 seconds of 25% cpu until the selected message appears in the message preview → v3, v3.1 Excruciatingly slow message read and switching, 10-15 seconds of 25% cpu until the selected message appears in the message preview, antivirus and firewall disabled
I use Norton Internet Security 2009.

Sadly, I can't do that test at the moment. The downgrade to TB2 gave me back the functionality. Upgrading to 3, testing and then downgrading again is too time consuming to take up just now.

If I have some spare time over Labor Day weekend, I'll try to give it a whirl and see what happens.
I believe this is caused by ug 599119. If is issue is not gone in version 3.1.5, then please reopen the bug.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 599119
I hope so. I liked 3.1 otherwise. But so far I am only being offered 3.1.4. I'll try 3.1.5 when it arrives and report back.
I got a chance to install 3.1.5 today. It does, indeed, seem to have fixed the bug so I guess that must have been it. Thanks for your efforts. I appreciate it.
You need to log in before you can comment on or make changes to this bug.