Status

()

Core
Networking
P3
normal
VERIFIED WORKSFORME
17 years ago
11 years ago

People

(Reporter: BenB, Assigned: BenB)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Fix in hand, URL)

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
Reproduce:
1. Help|About Mozilla
2. Click on "MPL"

Actual result:
Page fetched from www.mozilla.org displayed

Expected result:
MPL displayed, but no network hit.

Additional comments:
It might be a legal requirement to ship the licence, even with tarballs.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9
(Assignee)

Comment 1

17 years ago
Fixed in my N6.0 tree
(Assignee)

Comment 2

17 years ago
Getting schizophrenic: Moving all bugs for Beonex <http://www.beonex.com> to my
second Bugzilla identity <ben.bucksch@beonex.com>.
Assignee: mozilla → ben.bucksch
Status: ASSIGNED → NEW
(Assignee)

Comment 3

17 years ago
I will attach a patch. It will include the fix for bug 55660. Developed on
Linux. IIRC, it compiled on Windows, not tested on Mac.

gagan, please r= or tell someone to do so.
Status: NEW → ASSIGNED
Keywords: review
Target Milestone: mozilla0.9 → mozilla0.8
(Assignee)

Comment 4

17 years ago
Created attachment 22600 [details] [diff] [review]
Fix, version 1
(Assignee)

Comment 5

17 years ago
export POSIXLY_CORRECT=1
cvs diff -uN netwerk/build/nsNetModule.cpp
netwerk/protocol/about/src/Makefile.in netwerk/protocol/about/src/makefile.win
netwerk/protocol/about/src/nsAboutWelcome.cpp
netwerk/protocol/about/src/nsAboutWelcome.h
netwerk/protocol/about/src/nsAboutLicense.cpp
netwerk/protocol/about/src/nsAboutLicense.h xpfe/communicator/jar.mn
xpfe/communicator/resources/locale/en-US/MANIFEST
xpfe/communicator/resources/locale/en-US/welcome.html xpfe/global/jar.mn
xpfe/global/resources/locale/en-US/license.html
xpfe/communicator/resources/locale/en-US/Makefile.in
xpfe/communicator/resources/locale/en-US/makefile.win
xpfe/global/resources/locale/en-US/makefile.win
xpfe/global/resources/locale/en-US/Makefile.in 
xpfe/global/resources/locale/en-US/MANIFEST > 55659-1.diff

Comment 6

17 years ago
Ben: I don't think this should be done as separate files. All the about:foo that 
only redirect to another URL should be grouped together. And in the NewChannel 
we should check for the different cases and present the corresponding URL for 
it.
(Assignee)

Comment 7

17 years ago
gagan, I completely agree and thought of something similar. But this is another
bug (there are already 5 or so of these classes and I add only 2), which I don't
cannot/don't want to fix right now, and these bugs are fixed already and needed
for Beonex Comm..

Comment 8

17 years ago
I disagree. The 5/6 classes you refer to all do different things. The case in 
point (and about:welcome) only deals with the ones that are "redirected" to 
another location. And so these cases should just be extensions to the way 
about:credits works. What is beonex comm...?
(Assignee)

Comment 9

17 years ago
Ok, it's just 3, not 5, existing classes which just redirect:
- <about:>
- <about:credits>
- <about:mozilla>
Still...

> What is beonex comm...?

A product based on Mozilla. <http://www.beonex.com/communicator>

Comment 10

17 years ago
If anyone files a bug on making the about: redirects share more code, please 
make that bug block bug 66607 (about:privacy).
(Assignee)

Comment 11

17 years ago
Gagan, I don't see the big difference problem if we have 3 or 5 classes which
essentiall do that same. If you block this bug, all you achieve is that you
force me to keep local changes (-> hassles with patch and new files, conflicts
during merges etc.).

Comment 12

17 years ago
The difference is not just the additional classes which mean more memory space 
but also the extra files added for no benefit at all. And I can assure you the 
purpose of denying this checkin is not to make things difficult for you, but to 
make it better for the browser. Submit a patch that incorporates my suggestions 
of handling redirect cases in one class and then I'll review it. 
(Assignee)

Comment 13

17 years ago
Nobody reviewd so far :-(, so I have to move to Mozilla 0.9. Please review!
(Assignee)

Comment 14

17 years ago
> extra files added for no benefit at all

They sure have benefit for Beonex. How much code is in Mozilla that serves only
Netscape?

> Submit a patch that incorporates my suggestions

I have no time for such archtectural enhancements, at least not in the near
future. Actually, I wouldn't even know how to do it. I tried something like that
for about:<developer> back in 1999, IIRC, but gave up.

> Nobody reviewd so far :-(, so I have to move to Mozilla 0.9. Please review!

Ignore that - mass comment.
(Assignee)

Comment 15

17 years ago
I filed bug 68086 for the generic redirector class.
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.8 → mozilla0.9
(Assignee)

Comment 16

17 years ago
Gagan, how about |#ifdef|ing the code? This would remove the footprint from the
standard distro and avoid patches and cvs conflicts on my side.
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9 → mozilla0.9.1
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.1 → mozilla0.9.2

Comment 17

17 years ago
mass move, v2.
qa to me.
QA Contact: tever → benc
(Assignee)

Updated

17 years ago
Keywords: review
Whiteboard: Fix in hand
Target Milestone: mozilla0.9.2 → mozilla0.9.3
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.3 → ---

Comment 18

16 years ago
bug 68086 is fixed, can this be done easily now ?

Updated

16 years ago
Blocks: 96712

Updated

15 years ago
Keywords: review
note, by now such a redirector does exist (nsAboutRedirector.cpp)

Comment 20

15 years ago
ben: can you clarify what the status is since bug 68086 is fixed?

If that works, shouldn't you just be able to hook up about: URLs to anything you
want?
(Assignee)

Comment 21

15 years ago
This bug is fixed as far as Beonex Communicator is concerned, thanks in part to
gagan's work on bug 68086.

However, I think this is a good idea for Mozilla as well. It is arguable. It
leave it to the netlib module owners to decide, if this should be fixed (in
which case I can contribute the simple fix) or be WONTFIXed.

Comment 22

11 years ago
Isn't this fixed long ago? About:licence now results in a British English MPL, while about:license produces an American English MPL. Marking WFM.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 23

11 years ago
Are you kidding? There is no British English MPL. about:licence shows a license which spells "license" American. Nobody expected otherwise.

This bug was about shipping the license with the app, not spelling. I think that has been fixed long ago indeed, but can't verify right now.

Comment 24

11 years ago
V/wfm:

Seamonkey 1.1,2/macos.

Create new profile.
Go offline.
Go to about:license

OBSERVED:
viewed a license. Did not extensively check contents, but it looks like what was requested.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.