Last Comment Bug 556813 - [cn-sea-qm-win2k3-01, Debug SeaMonkey] content/xtf/test tries to install libs
: [cn-sea-qm-win2k3-01, Debug SeaMonkey] content/xtf/test tries to install libs
Status: VERIFIED FIXED
: regression
Product: SeaMonkey
Classification: Client Software
Component: Release Engineering (show other bugs)
: Trunk
: x86 Windows Server 2003
: -- major (vote)
: seamonkey2.1a1
Assigned To: Robert Kaiser (not working on stability any more)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-02 10:53 PDT by Serge Gautherie (:sgautherie)
Modified: 2010-04-03 08:42 PDT (History)
1 user (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Serge Gautherie (:sgautherie) 2010-04-02 10:53:43 PDT
{
make[7]: Entering directory `/e/builds/slave/comm-central-trunk-win32-debug/build/objdir/mozilla/content/xtf/test'
d:/mozilla-build/python25/python2.5.exe /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/config/nsinstall.py /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/crashinjectdll.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/gkgfx.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/layers.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/mozalloc.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/mozjs.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/mozqcms.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/mozreg_s.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/mozsqlite3.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/mozz.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/nspr4.dll /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/nspr4.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/nspr4.pdb /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/nspr4_s.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/plc4.dll /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/plc4.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/plc4.pdb /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/plc4_s.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/plds4.dll /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/plds4.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/plds4.pdb /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/plds4_s.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/rdfutil_external_s.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/thebes.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/unicharutil_external_s.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/unicharutil_s.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/vmwarerecordinghelper.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/xpcom.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/xpcom_core.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/xpcomglue.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/xpcomglue_s.lib /e/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/xpt.lib ../../../_tests/xpcshell/test_xtf/unit
make[7]: Leaving directory `/e/builds/slave/comm-central-trunk-win32-debug/build/objdir/mozilla/content/xtf/test'
Traceback (most recent call last):
  File "e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/config/nsinstall.py", line 155, in <module>
    sys.exit(nsinstall(sys.argv[1:]))
  File "e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/config/nsinstall.py", line 151, in nsinstall
    copy_all_entries(args, target)
  File "e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/config/nsinstall.py", line 119, in copy_all_entries
    handleTarget(e, dest)
  File "e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/config/nsinstall.py", line 143, in handleTarget
    shutil.copy(srcpath, targetpath)
  File "d:\mozilla-build\python25\lib\shutil.py", line 80, in copy
    copyfile(src, dst)
  File "d:\mozilla-build\python25\lib\shutil.py", line 46, in copyfile
    fsrc = open(src, 'rb')
IOError: [Errno 2] No such file or directory: 'e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/xtf/test/unit/crashinjectdll.lib'
make[7]: *** [libs] Error 1
}

I've no clue about this. (Related to bug 512490??)
Comment 1 Serge Gautherie (:sgautherie) 2010-04-02 11:07:23 PDT
Of course, bug 531340 regression makes it hard->impossible to know what/when happened.

Something odd:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1270218334.1270222058.6165.gz
WINNT 5.2 comm-central-trunk leak test build on 2010/04/02 07:25:34
is a previous failure, in the middle of the bug 531340 ones.
Could the cause be older than bug 488175 landing!?
Comment 2 Serge Gautherie (:sgautherie) 2010-04-02 11:31:36 PDT
(In reply to comment #1)

> is a previous failure, in the middle of the bug 531340 ones.

I checked "all" the build logs: I can't explain how this "in between" happened.

> Could the cause be older than bug 488175 landing!?

None of the other builds (so far) have this error.

The affected builds are the comment 1 one then
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1270226320.1270226876.20162.gz
WINNT 5.2 comm-central-trunk leak test build on 2010/04/02 09:38:40
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1270226906.1270227882.22933.gz
WINNT 5.2 comm-central-trunk leak test build on 2010/04/02 09:48:26
Comment 3 Serge Gautherie (:sgautherie) 2010-04-02 12:58:58 PDT
Wow! It seems intermittent:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1270230073.1270234458.8631.gz
WINNT 5.2 comm-central-trunk leak test build on 2010/04/02 10:41:13
doesn't have it (but has bug 531340 bustage).

Could it depend on build order?
Bug 531340 really needs to be fixed or back out first...
Comment 4 Chris Pearce (:cpearce) 2010-04-02 17:24:10 PDT
FYI: I pushed a bustage fix for bug 531340: http://hg.mozilla.org/mozilla-central/rev/3421c70b573d
Problem was the linker couldn't handle "class NS_COM_GLUE NS_STACK_CLASS MonitorAutoExit" on comm-central, removing "NS_COM_GLUE NS_STACK_CLASS" fixed it.
Comment 5 Serge Gautherie (:sgautherie) 2010-04-02 18:07:44 PDT
(In reply to comment #4)
> FYI: I pushed a bustage fix for bug 531340:

Thanks.

*****

This bug really is intermittent.!.

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1270240593.1270243104.30537.gz
WINNT 5.2 comm-central-trunk leak test build on 2010/04/02 13:36:33

Ah, they are all and only on 's: cn-sea-qm-win2k3-01'!
Could a clobber have gone bad or something?
Comment 6 Robert Kaiser (not working on stability any more) 2010-04-02 18:21:56 PDT
(In reply to comment #5)
> Ah, they are all and only on 's: cn-sea-qm-win2k3-01'!
> Could a clobber have gone bad or something?

No idea, but I clobbered again. As I guess that's now what this bug requests, marking fixed.
Comment 7 Serge Gautherie (:sgautherie) 2010-04-03 08:42:39 PDT
V.Fixed, per
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1270284081.1270294796.31329.gz
WINNT 5.2 comm-central-trunk leak test build on 2010/04/03 01:41:21
s: cn-sea-qm-win2k3-01

Note You need to log in before you can comment on or make changes to this bug.