SMTP server authencation is enabled after upgrading from 2.x

RESOLVED DUPLICATE of bug 522633

Status

Thunderbird
Migration
RESOLVED DUPLICATE of bug 522633
8 years ago
8 years ago

People

(Reporter: Joost de Bruijn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; nl; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; nl; rv:1.9.1.9) Gecko/20100317 Thunderbird/3.0.4

After upgrading from a Thunderbird 2.x-version to a Thunderbird 3.0.x version all the SMTP-servers are set to 'Secure authencation'. This is incorrect. The servers of my provider didn't support secure authencation with an username and password, so I can't send e-mail until I turn it off.

I had the problem at 6 different (from family, etc.) PC's, with Windows XP, Vista and 7.

Reproducible: Always

Steps to Reproduce:
Upgrade a Thunderbird 2.x-installation to a Thunderbird 3.x-installation.
Actual Results:  
All SMTP-servers are set to use secure authencation with username and password.

Expected Results:  
It has to adopt the settings that were made in Thunderbird 2.x.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.0

Comment 1

8 years ago
David, I thought that your second patch for bug 522633 had disabled the auto-probing for secure authentication for Thunderbird 3.0.2, still there?

Either way, it's a duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 522633

Comment 2

8 years ago
Yes, autoprobing for secure auth should be turned off in 3.0.2 - if trySecAuth is not set, we should not be setting useSecAuth.

Comment 3

8 years ago
To Joost: Do you remember which box was checked in the SMTP Server dialog?
Was it "Use secure authentication" or "Use name and password", which are different settings? Only the first case has been fixed thus far.
(Reporter)

Comment 4

8 years ago
To rsx11m: It was "Use name and password". Excuse me, I didn't describe it clearly!

Comment 5

8 years ago
No problem, thanks for confirming. That's actually a bug in the old TB 2.0 account wizard (see bug 556984 comment #13 for related discussion) which only surfaced after migration to 3.0, now handling authentication more strictly.

Comment 6

8 years ago
Sorry, make that bug 524868 comment #13...
You need to log in before you can comment on or make changes to this bug.