Closed Bug 556992 Opened 10 years ago Closed 9 years ago

"too much recursion": no events in views and unifinder and no tasks visible, only a part of the alarms (problems with indefinite recurring tasks and events?)

Categories

(Calendar :: Internal Components, defect, blocker)

x86
Windows XP
defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 494788

People

(Reporter: aryx, Unassigned)

Details

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091211 Sunbird/1.0b1

After upgrading from 0.9 to 1.0b1, the I see no events in unifinder and calendar view, task list is also empty. Calendars are listed as active, I see a part of the alarms I should see. This worked as expected in 0.9.

Error: too much recursion
Source File: file:///F:/Software/Buero/Kalender/Sunbird/1.0-Branch/Latest%20Milestone/modules/calUtils.jsm -> file:///F:/Software/Buero/Kalender/Sunbird/1.0-Branch/Latest%20Milestone/calendar-js/calUtils.js
Line: 1099

Error: too much recursion
Source File: file:///F:/Software/Buero/Kalender/Sunbird/1.0-Branch/Latest%20Milestone/modules/calUtils.jsm -> file:///F:/Software/Buero/Kalender/Sunbird/1.0-Branch/Latest%20Milestone/calendar-js/calRecurrenceInfo.js
Line: 537

Error: too much recursion
Source File: file:///F:/Software/Buero/Kalender/Sunbird/1.0-Branch/Latest%20Milestone/modules/calUtils.jsm -> file:///F:/Software/Buero/Kalender/Sunbird/1.0-Branch/Latest%20Milestone/calendar-js/calRecurrenceInfo.js
Line: 483

Error: too much recursion
Source File: file:///F:/Software/Buero/Kalender/Sunbird/1.0-Branch/Latest%20Milestone/modules/calUtils.jsm -> file:///F:/Software/Buero/Kalender/Sunbird/1.0-Branch/Latest%20Milestone/calendar-js/calUtils.js
Line: 814

Error: too much recursion
Source File: file:///F:/Software/Buero/Kalender/Sunbird/1.0-Branch/Latest%20Milestone/modules/calUtils.jsm -> file:///F:/Software/Buero/Kalender/Sunbird/1.0-Branch/Latest%20Milestone/calendar-js/calUtils.js
Line: 815

Error: too much recursion
Source File: file:///F:/Software/Buero/Kalender/Sunbird/1.0-Branch/Latest%20Milestone/modules/calUtils.jsm -> file:///F:/Software/Buero/Kalender/Sunbird/1.0-Branch/Latest%20Milestone/calendar-js/calUtils.js
Line: 1092

Error: too much recursion
Source File: file:///F:/Software/Buero/Kalender/Sunbird/1.0-Branch/Latest%20Milestone/modules/calUtils.jsm -> file:///F:/Software/Buero/Kalender/Sunbird/1.0-Branch/Latest%20Milestone/calendar-js/calUtils.js
Line: 1098

Error: too much recursion
Source File: file:///F:/Software/Buero/Kalender/Sunbird/1.0-Branch/Latest%20Milestone/modules/calUtils.jsm -> file:///F:/Software/Buero/Kalender/Sunbird/1.0-Branch/Latest%20Milestone/calendar-js/calRecurrenceInfo.js
Line: 488

Error: [Exception... "'[JavaScript Error: "too much recursion" {file: "file:///F:/Software/Buero/Kalender/Sunbird/1.0-Branch/Latest%20Milestone/components/calCompositeCalendar.js" line: 457}]' when calling method: [calIStatusObserver::spinning]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///F:/Software/Buero/Kalender/Sunbird/1.0-Branch/Latest%20Milestone/components/calCompositeCalendar.js :: anonymous :: line 457"  data: yes]

Error: Error selecting events with recurrence!
[Exception... "Unexpected error"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: file:///F:/Software/Buero/Kalender/Sunbird/1.0-Branch/Latest%20Milestone/modules/calUtils.jsm -> file:///F:/Software/Buero/Kalender/Sunbird/1.0-Branch/Latest%20Milestone/calendar-js/calStorageCalendar.js :: cSC_getEventFromRow :: line 1192"  data: no]
DB Error: not an error

Error: Error selecting non recurring todos by range!
[Exception... "Unexpected error"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: file:///F:/Software/Buero/Kalender/Sunbird/1.0-Branch/Latest%20Milestone/modules/calUtils.jsm -> file:///F:/Software/Buero/Kalender/Sunbird/1.0-Branch/Latest%20Milestone/calendar-js/calStorageCalendar.js :: cSC_getTodoFromRow :: line 1225"  data: no]
DB Error: not an error
Looks like two different issues. I can't find the bug, but we have a bug about "too much recursion" errors when switching tabs in Lightning.

The Database error is a bit strange. Looks like there is no sql error, but rather an xpcom exception. It would be interesting to find out where this exception comes from.
I have same problem. I am using CalDAV protocol with Lightning addon (nightly build, date 12.7.2010) with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.4) Gecko/20100620 Lightning/1.0b2pre Lanikai/3.1.1pre. 
The tab with calendar is repeateously reloaded (2-3 times per second) and from error console:
(many times)
Error: too much recursion
Source File: file:///C:/Documents%20and%20Settings/user/Application%20Data/Thunderbird/Profiles/cpsl7z69.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js
Line: 416
(and final exception)
Error: [Exception... "'[JavaScript Error: "too much recursion" {file: "file:///C:/Documents%20and%20Settings/user/Application%20Data/Thunderbird/Profiles/cpsl7z69.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js" line: 416}]' when calling method: [calICompositeCalendar::getItems]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://calendar/content/calendar-task-tree.xml :: anonymous :: line 954"  data: yes]

nightly builds of Ligthning are unusable from juny (I do no exact date) of this year. I am using version from 31.5.2010 which is working well.
Any action being taken on this? I'm getting this also, and it's making it impossible to use.
I've tested with and without the cache and I have those issues too.

It's quite easy to reproduce when you have many (6-8) large (500-1000 events) CalDAV calendars.
So I've tried moving the processing of the ical components in calIcsParser into the thread, but this causes segfaults and hangs.

I also tried experimenting with nsIProxyObjectManager, but this causes more frequent hangs. I believe we'll have to go the one or other route though. Daniel, do you have any input about the two methods? I guess there are some things that need to be proxied to the main thread.

When I use nsIProxyObjectManager with PROXY_ASYNC, then I get critical errors that something only for the main thread was used on a different thread.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 494788
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.11) Gecko/20101013 Lightning/1.0b2 Thunderbird/3.1.5

I get no "too much recursion" error like in bug 494788, but I've the same problem with my events:
regulary events sometimes show up complete, sometimes only parts of them, sometimes none of them. I've already moved e.g. all birthday reminder events to a new internal cal but the bug stays the same.

I also got this problem with other events, too and my task tab is also empty most of the time (comes and goes, too).

Hoped for bug resolve for months now but still there's no help in sight - what's the status here?
You need to log in before you can comment on or make changes to this bug.