Last Comment Bug 557481 - MathML start/demo pages: remove the alternate TeX and Mathematica stylesheets
: MathML start/demo pages: remove the alternate TeX and Mathematica stylesheets
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: MathML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: Frédéric Wang (:fredw)
:
:
Mentors:
Depends on:
Blocks: mathml-demos
  Show dependency treegraph
 
Reported: 2010-04-06 03:43 PDT by Frédéric Wang (:fredw)
Modified: 2011-08-08 05:52 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Change comments about TeX/Mathematica fonts to STIX/Asana fonts (mercurial) (1.91 KB, patch)
2011-07-11 12:04 PDT, Frédéric Wang (:fredw)
karlt: review+
karlt: checkin+
Details | Diff | Splinter Review
Change comments about TeX/Mathematica fonts to STIX/Asana fonts (svn) (13.14 KB, patch)
2011-07-11 12:04 PDT, Frédéric Wang (:fredw)
karlt: review+
karlt: checkin+
Details | Diff | Splinter Review
Change comments about TeX/Mathematica fonts to STIX/Asana fonts (svn, part 2) (1.85 KB, patch)
2011-08-06 11:54 PDT, Frédéric Wang (:fredw)
karlt: review+
karlt: checkin+
Details | Diff | Splinter Review

Description Frédéric Wang (:fredw) 2010-04-06 03:43:52 PDT
The start pages as well as other demos provide some alternate stylesheets

<link rel="alternate stylesheet" title="TeX" href="tex.css" />
<link rel="alternate stylesheet" title="Mathematica" href="mathematica.css" />

This was initially aimed at comparing the rendering of different fonts. However, these two fonts are no longer recommended and are in unwanted categories 3 and 4 of bug 400938 comment 0 (personnaly, when I select View->Page Style->Tex, some symbols become wrong). When we support more Unicode fonts for stretching, it will be possible to add alternate stylesheets for STIX, Cambria, Asana...
Comment 1 Frédéric Wang (:fredw) 2010-10-09 11:33:51 PDT
I think it would be a good idea to wait support for Asana Math which is underway (bug 407439). Then we can replace Tex/Mathematica by STIX/Asana.

Other things to remember:

1) remove -moz-math-font-style-stretchy ("old: compatible with pre-1.4 builds"). I believe it is the only remaining issue that prevents to close bug 346222.

2) change the comments/examples about -moz-math-stretchy in mozilla-central.

find mathml/ | xargs grep "\-"moz"\-"math"\-"stretchy

mathfont.properties:# :-moz-math-stretchy in mathml.css.
mathml.css:   mo[myfonts="tex"]::-moz-math-stretchy {
mathml.css:   mo[myfonts="mathematica"]::-moz-math-stretchy {
mathml.css:   ::-moz-math-stretchy {
mathml.css:::-moz-math-stretchy {
nsMathMLChar.cpp:    stretchy fonts held by the leaf style context (from -moz-math-stretchy in
Comment 2 Frédéric Wang (:fredw) 2011-07-11 12:04:24 PDT
Created attachment 545219 [details] [diff] [review]
Change comments about TeX/Mathematica fonts to STIX/Asana fonts (mercurial)
Comment 3 Frédéric Wang (:fredw) 2011-07-11 12:04:53 PDT
Created attachment 545220 [details] [diff] [review]
Change comments about TeX/Mathematica fonts to STIX/Asana fonts (svn)
Comment 4 Frédéric Wang (:fredw) 2011-07-11 12:07:28 PDT
I don't know if the UI to choose stylesheets is still relevant since Firefox no longer have a menu bar by default and we have to use Alt + V. But at least, these patches remove the old TeX/Mathematica code.
Comment 5 Karl Tomlinson (:karlt) 2011-08-04 22:41:22 PDT
Comment on attachment 545220 [details] [diff] [review]
Change comments about TeX/Mathematica fonts to STIX/Asana fonts (svn)

http://viewvc.svn.mozilla.org/vc?view=revision&revision=93366
Comment 6 Frédéric Wang (:fredw) 2011-08-06 11:54:42 PDT
Created attachment 551268 [details] [diff] [review]
Change comments about TeX/Mathematica fonts to STIX/Asana fonts (svn, part 2)

It seems that I forgot the changes that were outside the demo/ dir.
Comment 7 Karl Tomlinson (:karlt) 2011-08-07 22:44:36 PDT
Comment on attachment 551268 [details] [diff] [review]
Change comments about TeX/Mathematica fonts to STIX/Asana fonts (svn, part 2)

http://viewvc.svn.mozilla.org/vc?view=revision&revision=93439
Comment 8 Karl Tomlinson (:karlt) 2011-08-07 22:45:55 PDT
Comment on attachment 545219 [details] [diff] [review]
Change comments about TeX/Mathematica fonts to STIX/Asana fonts (mercurial)

http://hg.mozilla.org/integration/mozilla-inbound/rev/163605e2e60a
Comment 9 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-08-08 05:52:28 PDT
http://hg.mozilla.org/mozilla-central/rev/163605e2e60a

Note You need to log in before you can comment on or make changes to this bug.