Bug 553915 (update-mathml-doc)

Update MathML Documentation

RESOLVED FIXED

Status

()

Core
MathML
--
enhancement
RESOLVED FIXED
8 years ago
6 months ago

People

(Reporter: fredw, Assigned: fredw)

Tracking

({helpwanted, meta})

Trunk
helpwanted, meta
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

8 years ago
This is a meta bug to track bugs related to MathML documentation.

Comment 2

8 years ago
I'm happy to help with redirects if needed.  If someone else adds them, please use an .htaccess file instead of client-side redirects in the HTML pages.
Thanks very much, Frédéric.  That's looking great.
Looks like we should add these redirects now.  Is that what you are suggesting?

If so, David, can you put these in please?
(I expect you know the issues/options much better than I.)
(Assignee)

Comment 4

8 years ago
> Looks like we should add these redirects now.  Is that what you are suggesting?
> If so, David, can you put these in please?

Yes, that's what I'm suggesting. I would be graceful if David could do that.

Comment 6

8 years ago
These four redirects are now in place, please confirm they're working as intended.

A couple questions:

Is the goal to move all of the MathML content from mozilla.org to MDC?  I'm happy to help with that if it is.

Are there any supporting files that go along with any of these redirected pages, like images in the screenshots directory, that can be removed as well?
(Assignee)

Comment 7

8 years ago
Thanks, it works as expected.

> Is the goal to move all of the MathML content from mozilla.org to MDC?  I'm happy to help with that if it is.

The goal is to move the content either to MDC (general information on the MathML project) or to wiki.mozilla.org (more oriented toward Gecko's developers). We have to collect and update the relevant info. It is not clear yet what to do with some "historical" contents such that conf2000/. Anyway, we still plan to use the http://www.mozilla.org/projects/mathml/ to store XHTML+MathML demos, until we find a solution to have MathML on Mozilla wikis. Thank you for your help, we'll inform you on this bug when more content is moved.

> Are there any supporting files that go along with any of these redirected pages, like images in the screenshots directory, that can be removed as well?

mathboard.gif
screenshots/viewsource.png
You can also remove demo/tester.html.
(Assignee)

Comment 8

8 years ago
you can also remove build.html

Comment 9

8 years ago
Great, thanks for the explanation.

In terms of what to do with historical content, we've set up an archive server that clearly states that things are out-of-date but historically relevant.  If we remove any content, such as the conf2000 pages, and people still try to get to it, they'll be automatically redirected to the archive site at

http://www-archive.mozilla.org/projects/mathml/conf2000/

So if you have content that isn't current but you don't want to delete, we can just remove it from the SVN repository of the www.mozilla.org site and it will still be around on the archive site.

I've also removed the files you mentioned in #7 and #8.
(Assignee)

Comment 10

8 years ago
> So if you have content that isn't current but you don't want to delete, we can
> just remove it from the SVN repository of the www.mozilla.org site and it will
> still be around on the archive site.

OK, in that case you can clean up any further and remove these files:

- conf2000/
- update-1999-Sep-18.html, frames.gif, mfrac-screenshot.gif, rendering.gif, dictionary.gif
- update-2000-Apr-14.html, thomson.gif, thomson.gif, stretchy.gif, trees.gif, thomson.html
- authoring.xhtml, authoring-example.xhtml

and add a redirect 
authoring.xhtml => https://developer.mozilla.org/en/Mozilla_MathML_Project/Authoring

For the demos I can use *.xml file on MDC for XHTML+MathML. But I'm wondering what is the behavior of Internet Explorer with these files:
- http://www.mozilla.org/projects/mathml/demo/texvsmml.xhtml
- https://developer.mozilla.org/@api/deki/files/4272/=itex2MML.xml
(I haven't IE on my system so I can not check.)
(Assignee)

Comment 11

8 years ago
> 
> OK, in that case you can clean up any further and remove these files:
 
as well as fonts/bakoma and fonts/stix

Comment 12

8 years ago
Those files in #10 and #11 have been removed and the authoring.html redirect has been set up (although it will take a few minutes to make it to the live site).
(Assignee)

Updated

8 years ago
Depends on: 557480
(Assignee)

Updated

8 years ago
Depends on: 557481
(Assignee)

Updated

8 years ago
Depends on: 557482
(Assignee)

Updated

8 years ago
Keywords: helpwanted
(Assignee)

Updated

8 years ago
Keywords: meta
(Assignee)

Updated

8 years ago
Depends on: 585139
(Assignee)

Updated

8 years ago
Depends on: 585141
(Assignee)

Updated

8 years ago
Depends on: 585142
(Assignee)

Updated

8 years ago
No longer depends on: 192644, 445029, 557480, 557481, 557482
(Assignee)

Comment 13

8 years ago
The following gifs in http://www.mozilla.org/projects/mathml/screenshots/ can be removed and the corresponding redirections can be added:

ex1.gif => https://developer.mozilla.org/@api/deki/files/4578/=ex1.png
ex2.gif => https://developer.mozilla.org/@api/deki/files/4579/=ex2.png
ex21.gif => https://developer.mozilla.org/@api/deki/files/4586/=ex21.png
ex22.gif => https://developer.mozilla.org/@api/deki/files/4587/=ex22.png
ex23.gif => https://developer.mozilla.org/@api/deki/files/4588/=ex23.png
ex24.gif => https://developer.mozilla.org/@api/deki/files/4589/=ex24.png
ex25.gif => https://developer.mozilla.org/@api/deki/files/4590/=ex25.png
ex26.gif => https://developer.mozilla.org/@api/deki/files/4591/=ex26.png
ex27.gif => https://developer.mozilla.org/@api/deki/files/4592/=ex27.png
ex29.gif => https://developer.mozilla.org/@api/deki/files/4593/=ex29.png
ex3.gif => https://developer.mozilla.org/@api/deki/files/4580/=ex3.png
ex30.gif => https://developer.mozilla.org/@api/deki/files/4594/=ex30.png
ex31.gif => https://developer.mozilla.org/@api/deki/files/4595/=ex31.png
ex34.gif => https://developer.mozilla.org/@api/deki/files/4596/=ex34.png
ex4.gif => https://developer.mozilla.org/@api/deki/files/4581/=ex4.png
ex40.gif => https://developer.mozilla.org/@api/deki/files/4597/=ex40.png
ex41.gif => https://developer.mozilla.org/@api/deki/files/4599/=ex41.png
ex43.gif => https://developer.mozilla.org/@api/deki/files/4600/=ex43.png
ex44.gif => https://developer.mozilla.org/@api/deki/files/4601/=ex44.png
ex5.gif => https://developer.mozilla.org/@api/deki/files/4582/=ex5.png
ex51.gif => https://developer.mozilla.org/@api/deki/files/4602/=ex51.png
ex52.gif => https://developer.mozilla.org/@api/deki/files/4603/=ex52.png
ex53.gif => https://developer.mozilla.org/@api/deki/files/4604/=ex53.png
ex54.gif => https://developer.mozilla.org/@api/deki/files/4605/=ex54.png
ex6.gif => https://developer.mozilla.org/@api/deki/files/4598/=ex6.png
ex7.gif => https://developer.mozilla.org/@api/deki/files/4583/=ex7.png
ex8.gif => https://developer.mozilla.org/@api/deki/files/4584/=ex8.png
ex9.gif => https://developer.mozilla.org/@api/deki/files/4585/=ex9.png
(Assignee)

Comment 14

7 years ago
Now Firefox 4 is out, I've updated the MathML Fonts page to tell people to use STIX 1.0 instead of STIX beta.

I think we need to check the doc and update pages to mention new MathML features. At least, Mozilla_MathML_Project/Authoring should be modified to say that the XML syntax is no longer mandatory and to provide an example with the HTML5 syntax. Florian, do you mind doing that?
(Assignee)

Comment 16

7 years ago
(In reply to comment #15)
> Updated: https://developer.mozilla.org/en/Mozilla_MathML_Project/Authoring
> 
> Diff:
> https://developer.mozilla.org/index.php?title=en/Mozilla_MathML_Project/Authoring&action=diff&revision=30&diff=32

Thanks, it looks good.

I've also seen you have made good job to document MathML presentation elements! If you plan to document <mstyle/>, I want to tell you that this element is a bit special, because it does not follow exactly the same inheritance rules as CSS. Moreover, our current implementation does not always behaves correctly with respect to these rules (bug 569125). I think it is worth mentioning this in the doc, since most people are not aware of the subtility of mstyle (I was not even aware myself before working on the Mozilla's implementation!). Also, there has been a change in MathML3: the <math/> element can be used as a <mstyle/> (bug 569124). I've cc'ed you to the relevant bugs, so that you will know when you can update the reference pages. Thank you again for your contribution to the MathML doc.
(Assignee)

Comment 17

7 years ago
For some reason, the demo pages (for instance 
http://www.mozilla.org/projects/mathml/demo/texvsmml.xhtml) are no longer available.

Comment 18

7 years ago
(In reply to Frédéric Wang (:fred) from comment #17)
> For some reason, the demo pages (for instance 
> http://www.mozilla.org/projects/mathml/demo/texvsmml.xhtml) are no longer
> available.

With the recent www.mozilla.com/.org merge there were some Apache changes and it is likely that this is the cause of the problem.  Opened bug 683744 for the issue about not serving .xhtml files.
(Assignee)

Updated

7 years ago
Alias: update-mathml-doc
(Assignee)

Comment 19

4 years ago
This meta bug can probably be closed now.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 months ago
Assignee: nobody → fred.wang
You need to log in before you can comment on or make changes to this bug.