If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Buttons have over-extending vertical lines -- they shouldn't!

VERIFIED FIXED in 5.9

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
8 years ago
2 years ago

People

(Reporter: stephend, Unassigned)

Tracking

unspecified

Details

(Whiteboard: [z][buttons], URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 437440 [details]
Screenshot of the vertical lines

See screenshot; there's a weird vertical line on the Add to Firefox/Download Now experiences.
(Reporter)

Updated

8 years ago
Summary: Buttons have vertical lines -- they shouldn't! → Buttons have over-extending vertical lines -- they shouldn't!
(In reply to comment #0)
> See screenshot; there's a weird vertical line on the Add to Firefox/Download

Looks like it's caused by the following rule in common-min.css (defined around line 2780 in main.css before minimizing):

.section-teaser .addon-view p,
.section-teaser .addon-view h3 {
    margin-left: 0;
    margin-right: 0;
    line-height: 1.23em;
}

That's declaring an explicit line-height, and that smaller line-height is making the icon border overflow the button. Buttons expect the base line-height of 1.538 as declared for the body, but to play it safe we can explicitly declare that line-height for buttons.

Fixed in r65389
(Reporter)

Updated

8 years ago
Target Milestone: --- → 5.9
(Reporter)

Comment 2

8 years ago
Hey Craig - I've given your Bugzilla account permissions to edit bugs now, so please resolve as needed; thanks.
(In reply to comment #2)
> Hey Craig - I've given your Bugzilla account permissions to edit bugs now, so
> please resolve as needed; thanks.

Marking as resolved. Thanks, Stephen.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

8 years ago
This needs merging into Zamboni, looks like.
(Reporter)

Comment 5

8 years ago
Verified FIXED, thanks!
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.