OOPP crash notification bar doesn't show for small plugins

RESOLVED FIXED in mozilla1.9.3a5

Status

()

Core
Plug-ins
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Pike, Assigned: Dolske)

Tracking

({regression, verified1.9.2})

1.9.2 Branch
mozilla1.9.3a5
x86
Linux
regression, verified1.9.2
Points:
---

Firefox Tracking Flags

(blocking1.9.2 .4+, status1.9.2 .4-fixed)

Details

(Whiteboard: [3.6.3plugin1])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
On http://flashcrash.dempsky.org/ with a userContent.css of

@-moz-document domain(flashcrash.dempsky.org) {
   embed {
     width: 1px !important;
     height: 1px !important;
   }

} 

I don't see the notification bar for a crashed plugin.

Fehler: [Exception... "'JavaScript component does not have a method named: "observe"' when calling method: [nsIObserver::observe]"  nsresult: "0x80570030 (NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED)"  location: "<unknown>"  data: no]

is the last error in the error console.

Reading the last two messages on http://groups.google.com/group/mozilla.dev.l10n/browse_frm/thread/05b4bf36bbb4f6cc#, that's a regression on lorentz.

Tested on a lorentz nightly from the 6th.

Updated

8 years ago
Assignee: nobody → dolske
blocking1.9.2: --- → ?

Updated

8 years ago
Whiteboard: [3.6.3plugin1]
Benjamin suspects a bad merge!
blocking1.9.2: ? → .4+
(Assignee)

Comment 2

8 years ago
Are you sure that was a Lorentz nightly from the 6th? That specific error was fixed by one of the patches in bug 554214, which landed on 3/24. I suspect your nightly wasn't up to date.

However, a current 1.9.2 (post-Lorentz-merge) still fails to show the notification bar, albeit with a different error. After fixing that, it works fine for me. Patch coming next.
(Reporter)

Comment 3

8 years ago
oops, I guess I unpacked the wrong build. I'll wait with more tests 'til your patch lands.
(Assignee)

Comment 4

8 years ago
Created attachment 437694 [details] [diff] [review]
Patch v.1
Attachment #437694 - Flags: review?(gavin.sharp)
Attachment #437694 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 5

8 years ago
Looks like this happened because this conditional was added by bug 553371, and the patch for bug 544936 landed right after, and didn't change this instance of |minidumpID|.
Blocks: 544936
(Assignee)

Comment 6

8 years ago
Note that this is broken on trunk too!
(Assignee)

Updated

8 years ago
Summary: OOPP notification bar doesn't show for almost invisible plugins → OOPP crash notification bar doesn't show for small plugins
(Assignee)

Comment 7

8 years ago
Pushed http://hg.mozilla.org/mozilla-central/rev/f9bbdcfe2d1b
Pushed to 192: http://hg.mozilla.org/releases/mozilla-1.9.2/rev/c7c0e410f7e7
Status: NEW → RESOLVED
Last Resolved: 8 years ago
status1.9.2: --- → .4-fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a5
Verified fixed in build 1 of 1.9.2.4.
Keywords: verified1.9.2
You need to log in before you can comment on or make changes to this bug.