Unable to scroll DIV using arrows icon when onMouseDown="return false"

RESOLVED DUPLICATE of bug 511075

Status

()

RESOLVED DUPLICATE of bug 511075
9 years ago
9 years ago

People

(Reporter: masykora, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; Trident/4.0; User-agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; http://bsalsa.com) ; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; cs; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)

See testcase in steps-to-reproduce.

Reproducible: Always

Steps to Reproduce:
Try following testcase in Firefox 3.6 and previous versions:

<html>
<body>

<div style="width: 500px; height: 100px; border: 1px solid black; overflow: scroll" onmousedown="return false">

Steps-to-reproduce:
<ol>
<li>try to scroll using middle bar or scroll wheel => it works
<li>try to scroll using arrows or clicking on scrollbar => bug
</ol>

"Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum."
</div>

</body>
</html>
Actual Results:  
Cannot scroll.

Comment 1

9 years ago
I think that this is as same as Bug 511075  - The arrows of the scrollbars don´t work in hotmail.
(Reporter)

Comment 2

9 years ago
I agree, sorry than I didn't find it, feel free to mark as DUPLO. My application is webmail client too.
per Comments 1 & 2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 511075
You need to log in before you can comment on or make changes to this bug.