Closed Bug 511075 Opened 12 years ago Closed 11 years ago

The arrows of the scrollbars don't work in hotmail (event.preventDefault() causes clicks on scrollbars to be ignored)

Categories

(Core :: DOM: Events, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- final+
status1.9.2 --- .4-fixed

People

(Reporter: elguerreroesp, Assigned: smaug)

References

(Depends on 1 open bug)

Details

(Keywords: regression, testcase)

Attachments

(3 files, 2 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a2pre) Gecko/20090817 Namoroka/3.6a2pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a2pre) Gecko/20090817 Namoroka/3.6a2pre (.NET CLR 3.5.30729)

When I sign in hotmail the arrows of the scrollbar in the inbox don´t work. This happens only int the name of the mails. Sorry for my English, I´m Spanish.

Reproducible: Always

Steps to Reproduce:
1.Sign in hotmail.
2.Go to inbox.
3.The arrows in scrollbar don´t work.
The arrows don't work in 3.6 beta 5 as well. They work fine in 3.5.x.
Flags: blocking-firefox3.6?
This worked for me on w32, Juan, can you take a look and renominate if you can reproduce?
Flags: blocking-firefox3.6?
It might be worth trying Spanish localizations (of Hotmail, the browser, and the OS) if you can't reproduce in English.
I'm in the US and can confirm this on 2 separate installations - Windows XP (32-bit) and Windows 7 (64-bit). When I log into Hotmail, click on Inbox, the scroll arrows in the upper pane (to scroll down the messages pane) does not work for the arrows. The scroll arrows in the lower pane work fine. Kindly confirm that your upper pane scroll arrows work.
Flags: blocking-firefox3.6?
Mozilla/5.0 (Windows; U; Windows NT 5.1; es-MX; rv:1.9.2b5) Gecko/20091204 Firefox/3.6b5 (.NET CLR 3.5.30729) Latest version of Flash.

I tried that on es-mx, es-es, on a VM as well as in hardware on XP (OS installation in Spanish); I clicked on the scrollbars' arrows for the page. Same in individual messages long enough to display scrollbars. Both horizontal and vertical scrollbars. Works for me.

Reporter, are you running any(which) addons? When I use NoScript, for example, my experience in Hotmail is pretty unpleasant.

Are there different versions of Hotmail these days? IE and FX are giving me the same experience on these machines, so at least I get consistent results on my personal account.
Flags: blocking-firefox3.6?
Problem: Hotmail top pane scroll arrows do not work.
Add-ons: Firegestures, Flashblock. I tried uninstalling both of them and got the same result. 

Do the plugins make a difference? I have 3.5.6 installed and installed 3.6 b5 using the same profile. Hotmail is the only e-mail provider which which I have a problem and that is just with 3.6. 3.5 does not have the issue.
To reproduce you have to use the non-default setting on hotmail to use "panes", which is probably why other people haven't been able to reproduce.

It is caused by bug 311053.
Blocks: 311053
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
So is the page just calling preventDefault() and not expecting that to have an effect?
Component: General → XUL
Product: Firefox → Core
QA Contact: general → xptoolkit.widgets
As mentioned in comment# 7, this is easily reproduced if you click on the Options link which then shows a drop-down menu where you can change the "Reading pane settings" from Off to Right or Bottom. It also happens at least on Mac, and it has been like that for a very long time. I'll renominate to get it triaged.
Flags: blocking1.9.2?
Feels like a tech evangelism bug based on comment 7 and comment 8, no? I don't think it's a release blocker based on the fact that it's a non-standard option for Hotmail, but I'll add a relnote.
Keywords: regression, relnote
Flags: blocking1.9.2? → blocking1.9.2-
True, it may be a non-standard option in Hotmail, but why was it working in 3.5.x and is broken in the new version? The argument can be made that this is currently _known_ to be broken only in Hotmail, but the bug can easily affect other sites as well. It is a newly introduced bug in 3.6 and should be tracked separately. Have we confirmed that bug 311053 is the cause? If so, the status of that bug shows up as fixed. If that bug (or a new one) is not reopened, do we know this issue will be fixed?
Note that the same issue is reported in bug 530237 for the Excel Web App. I'm trying to get a simple repro to help track down the root issue, but I do know that there's nothing in our app that is swallowing those mouse messages for the scrollbars. Note that this is a regression in 3.6 since everything works fine in 3.5.
This is also being reported in the forum (http://support.mozilla.com/nl/forum/1/550043) as it also affects http://www.snopes.com/katrina/soapbox/snowfall.asp.

Seems like this should be investigated.
Attached file testcase
Based on the snopes link. It seems bug 311053 allowed js to override clicks to scrollbars.
We run into this problem in our JavaScript framework qooxdoo as well <http://bugzilla.qooxdoo.org/show_bug.cgi?id=3357>. We hope to be able to fix it in the framework but all existing application will have to be updated. For this reason this is a pretty severe bug for us.
This is also being reported in the forum
http://support.mozilla.com/en-US/forum/1/564719
bug 524401 is a duplicate. How did a major release go out with bug 311053?
Duplicate of this bug: 524401
(In reply to comment #17)
> How did a major release go out with bug 311053?

Bug 311053 was landed eleven months ago, so unless you are saying that this is a regression *because of* that bug, I don't see the logic.
(In reply to comment #19)
> Bug 311053 was landed eleven months ago, so unless you are saying that this is
> a regression *because of* that bug, I don't see the logic.

That is what I was saying. What I should have said was, "How did a major release go out with bug 511075?"
Possibly related with bug 520501...? (Sorry if this sounds like noise, given that the bug is actually around the scrollbar thumb.)
(In reply to comment #10)
> Feels like a tech evangelism bug based on comment 7 and comment 8, no?

This is not a tech evangelism bug based on comment 14.
Keywords: testcase
The OpenExchange interface is affected by this, too.

What is weird here is that only the scrollbars for the folder panel (top left) are affected, all the other ones do work fine.
I see this bug as well with WinXP Prof SP3 English and FF 3.6 using hotmail.  (btw Reading panes used to be the default and I have inherited them through the ages.)
Hi, this is my first post ever on here so I hope you don't feel this post is in the wrong spot but I thought it was appropriate to put here as this is the closest issue to mine. I use Yahoo Mail, and I am having the same problem with Yahoo Mail (I think). I can't use the scroll feature with my mouse. I use a reading pane as well. Whether I'm in the body of the email, or in the main screen with the reading pane I can't scroll up or down (using  the middle roller button on my mouse). If I click the arrows on the right to go up and down they work fine... Is this at all relevant to this post? If not, can someone direct me to where I can present this issue perhaps? I just want to help make the community aware of the problem so it can be fixed for other users. Also, If there's anything I can do to help I'd be more than willing. Thanks!
Duplicate of this bug: 552484
blocking2.0: --- → ?
possibly related to Bug 489667?
Yeah, that is the same bug.
NOT FIXED IN 3.6.2
Scrolling through emails in hotmail does not work properly in Firefox 3.6.2 on Mac.  Dragging blue scroll blob up or down DOES work, but use of arrows or clicking below or above scroll blob DOES NOT work.  Safari works fine, so this is clearly a firefox issue.  By the way, it worked fine in earlier versions, just appeared in the last 1 or 2 version upgrades.
Duplicate of this bug: 554528
Duplicate of this bug: 558276
Summary: The arrows of the scrollbars don´t work in hotmail. → The arrows of the scrollbars don't work in hotmail.
Severity: minor → normal
Component: XUL → DOM: Events
QA Contact: xptoolkit.widgets → events
Summary: The arrows of the scrollbars don't work in hotmail. → The arrows of the scrollbars don't work in hotmail (event.preventDefault() causes clicks on scrollbars to be ignored)
Per the letter of the DOM spec, this is probably the right behavior... if the default click behavior is to move the scrollbar and you call preventDefault(), the scrollbar shouldn't move.  I assume no other browser actually does that, though?
Yeah,  as far as I see this is the correct behavior. And IIRC we have always
had this behavior if event propagation and default handling has been stopped
early enough (in capture phase).

So this could be evang bug, or we need to change native anonymous scrollbar handling. Perhaps the latter to get better backwards compatibility.
Taking.
Assignee: nobody → Olli.Pettay
Status: NEW → ASSIGNED
(In reply to comment #33)
>  And IIRC we have always
> had this behavior if event propagation and default handling has been stopped
> early enough (in capture phase).
Actually, I'm probably wrong about this.

Anyway, the current behavior is right, but perhaps we can't keep it.

Patch coming soon.
(In reply to comment #25)
> Hi, this is my first post ever on here so I hope you don't feel this post is in
> the wrong spot but I thought it was appropriate to put here as this is the
> closest issue to mine. I use Yahoo Mail, and I am having the same problem with
> Yahoo Mail (I think). I can't use the scroll feature with my mouse. I use a
> reading pane as well. Whether I'm in the body of the email, or in the main
> screen with the reading pane I can't scroll up or down (using  the middle
> roller button on my mouse). If I click the arrows on the right to go up and
> down they work fine... Is this at all relevant to this post? If not, can
> someone direct me to where I can present this issue perhaps? I just want to
> help make the community aware of the problem so it can be fixed for other
> users. Also, If there's anything I can do to help I'd be more than willing.
> Thanks!
So how is this related to this bug? Isn't this bug about not being able to scroll using arrows, and seems like here the arrows work but something else doesn't.
Attached patch patch (obsolete) — Splinter Review
This fixes the testcase.
I uploaded the patch to tryserver and will post link to the builds once the
builds are ready.
Thanks for the build; I have just tested it using hotmail and it fixes the issue regarding the scroll arrow; but if you click on the scrollbar space it still does not scroll down (see screenshot).  I suspect this is a second (probably related) issue -- do you want me to put it in a fresh bug?
One correction, the right hand scroll-bar does work as expected, but the left-hand one doesn't.  Both can be grabbed and dragged.
Sorry, I don't understand what does "right hand scroll-bar" mean?
If you look at the attached image you see that I circled the spaces within two scroll-bars.  The left-hand scroll-bar is next to the list of emails and if you click within that space it should scroll down to where you click but doesn't.  The right hand scroll-bar is next to the mail message and does scroll down when you click in the space.  Hope that's a bit clearer; if not mail me directly and I'll chat to you on IRC or whatever.  Cheers.
Attached patch v2 (obsolete) — Splinter Review
I'll post this to tryserver.
Attachment #438259 - Attachment is obsolete: true
Look for scrollarrow_2 in https://build.mozilla.org/tryserver-builds/?C=M;O=D
in an hour or two
Excellent; that fixed the issue, both sliders work as expected.  Will this fix also be landed on 1.9.2?  Thanks, much appreciated.
Comment on attachment 438280 [details] [diff] [review]
v2

Neil, what do you think of this?

And yes, this should land on 1.9.2.x, and that was the reason why I took this pretty safe approach here.

I'll write tests for this.
Attachment #438280 - Flags: review?(enndeakin)
Thanks!
Attached patch +testsSplinter Review
The tests pass at least on Linux and OSX, and I posted the patch to
tryserver to verify that it works also on Windows.
Attachment #438280 - Attachment is obsolete: true
Attachment #438357 - Flags: superreview?(neil)
Attachment #438357 - Flags: review?(enndeakin)
Attachment #438280 - Flags: review?(enndeakin)
Attachment #438357 - Flags: superreview?(neil) → superreview+
I can confirm testing with Win XP Pro SP3 and the build from opettay@mozilla.com-scrollarrow2.  It passed all the tests I did with the hotmail email web page.  If you want me to do any other testing let me know.
Just tested with the build at https://build.mozilla.org/tryserver-builds/opettay@mozilla.com-scrollarrow2_with_tests/ using XP SP3 and this also works using hotmail.com.
Blocks: 489667
Attachment #438357 - Flags: review?(enndeakin) → review+
Comment on attachment 438357 [details] [diff] [review]
+tests

>+  function() {
>+    ok(true, "Setting location.hash should scroll.");
>+    nextTest();
>+    // Click the top scroll arrow.
>+    var x = scroller.getBoundingClientRect().width - 5;
>+    synthesizeMouse(scroller, x, 5, { type : "mousedown" }, window);
>+    synthesizeMouse(scroller, x, 5, { type: "mouseup" }, window);

You could just call synthesizeMouse once and leave out the type.

I suppose the test happens to work on Mac, even when the scroll up button is at the bottom of the scroll bar?
(In reply to comment #52)
> You could just call synthesizeMouse once and leave out the type.
I know. I just wanted to be more clear what is actually tested here. 

> I suppose the test happens to work on Mac, even when the scroll up button is at
> the bottom of the scroll bar?
Uh, right. Well it just happens to work :)
http://hg.mozilla.org/mozilla-central/rev/1fd66a6b0129

Will nominate for 1.9.2.x if the tests pass also on trunk tbox.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Attachment #438357 - Flags: approval1.9.2.4?
Comment on attachment 438357 [details] [diff] [review]
+tests

a=LegNeato for 1.9.2.4 as the patch doesn't look too risky and this is a 3.6 regression
Attachment #438357 - Flags: approval1.9.2.4? → approval1.9.2.4+
Depends on: 559272
Can confirm this is working for hotmail for me on XP in v.3.6.4 Beta (Build 1)
(Removing relnote tag)
Keywords: relnote
Depends on: 586655
blocking2.0: ? → final+
Depends on: 686022
No longer depends on: 686022
Depends on: 798806
You need to log in before you can comment on or make changes to this bug.