[HTML5][Patch] <button> should not be scoping

VERIFIED FIXED

Status

()

Core
HTML: Parser
P2
major
VERIFIED FIXED
8 years ago
6 months ago

People

(Reporter: Virtual, Assigned: hsivonen)

Tracking

({nightly-community})

Trunk
x86
Windows XP
nightly-community
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl-PL; rv:1.9.3a5pre) Gecko/20100408 Minefield/3.7a5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100408 Minefield/3.7a5pre

Just compere with html5 enabled and disabled.
Also with html5 all links cant be clicked (except only this upper menu) and searchbar is rendered on wrong place

Reproducible: Always

Steps to Reproduce:
1. enable HTML5 (about:config => html5.enable=true)
2. go to http://www.gf-hunters.de/
Actual Results:  
Wrongly rendered site

Expected Results:  
Properly rendered site with clickable working links
That pref just controls the parser; it has nothing to do with layout.

Henri, can you please take a look?  It looks like the relevant part of the markup is:

 <button type="submit" id="searchsubmit" value="" />
</form>

which is an unclosed button; this causes all the rest of the web page to be inside the button with the HTML5 parser.  I presume the </form> closes the button in the old parser?
Status: UNCONFIRMED → NEW
Component: Layout → HTML: Parser
Ever confirmed: true
QA Contact: layout → parser
This markup works in Safari and Opera too, so probably needs a spec change to support it.
Though I can't figure out _why_ it works in opera....  Maybe it lets links inside buttons be clickable?  Certainly live dom viewer claims the links are inside the button.
Blocks: 373864
Summary: enabled HTML5 causing site to renderer wrong without clickable links → [HTML5] enabled HTML5 causing site to renderer wrong without clickable links
(Assignee)

Comment 4

8 years ago
Looks like <button> should not be a scoping element. I wonder why it is per spec.

Furthermore, </form> should pop stuff more aggressively when the element pointed to by the form pointer is in scope.
(Assignee)

Comment 5

8 years ago
(In reply to comment #4)
> Looks like <button> should not be a scoping element. I wonder why it is per
> spec.
> 
> Furthermore, </form> should pop stuff more aggressively when the element
> pointed to by the form pointer is in scope.

It's sufficient to make <button> non-scoping. Changing how </form> is handled is not necessary.

Filed a spec bug:
http://www.w3.org/Bugs/Public/show_bug.cgi?id=9496
(Assignee)

Updated

8 years ago
Summary: [HTML5] enabled HTML5 causing site to renderer wrong without clickable links → [HTML5] <button> should not be scoping
(Assignee)

Comment 6

8 years ago
Created attachment 438722 [details] [diff] [review]
Make <button> non-scoping

The spec got changed:
http://html5.org/tools/web-apps-tracker?from=5031&to=5032
Assignee: nobody → hsivonen
Status: NEW → ASSIGNED
Attachment #438722 - Flags: review?(bnewman)
(Assignee)

Updated

8 years ago
Summary: [HTML5] <button> should not be scoping → [HTML5][Patch] <button> should not be scoping
Attachment #438722 - Flags: review?(bnewman) → review+
(Assignee)

Comment 7

8 years ago
http://hg.mozilla.org/mozilla-central/rev/739aec32e63e
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Depends on: 569528

Updated

7 years ago
Depends on: 621630
No longer depends on: 621630
You need to log in before you can comment on or make changes to this bug.