If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Plugin crash reports are always sent, ignoring 'Submit crash reports' checkbox in Options

RESOLVED DUPLICATE of bug 577221

Status

()

Toolkit
Crash Reporting
RESOLVED DUPLICATE of bug 577221
8 years ago
7 years ago

People

(Reporter: Danny, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100410 Minefield/3.7a5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100410 Minefield/3.7a5pre

Can't disable submitting reports when plugin crashes.

Reproducible: Always

Steps to Reproduce:
1. Go to Options -> Advanced -> General and uncheck 'Submit crash reports' checkbox.
2. Open flashcrash.dempsky.org webpage.
3. Wait until Flash plugin crashes but do nothing.
4. Open about:crashes page.
Actual Results:  
Crash report is submitted, though I especially forbid it in 'Options' and did not sent it manually.

Expected Results:  
No crash report submitted.
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk

Comment 1

7 years ago
I can confirm this and have some additional information.

1) The state does not change.  I my case it is unchecked, I check it and go back to tools --> Options --> General and it is unchecked.

2) This seems odd but it seems to happen only in a Windows admin account.  In both my case and the OP here http://forums.mozillazine.org/viewtopic.php?f=38&t=1929941 the check mark will stick if we are not in an admin account. Once you return to an admin account the check mark returns to what it was before.

Comment 2

7 years ago
Sorry for the bug spam.  However it seems to be a profile issue of some sort.

1) Using my default profile, problem exists in regular and safe mode.
2) A new, clean profile and the problem goes away.

I will doe some testing later today to see what is causing the problem.

Updated

7 years ago
Component: General → Breakpad Integration
Product: Firefox → Toolkit
QA Contact: general → breakpad.integration
This preference is read from the registry, and we first check HKEY_LOCAL_MACHINE, and then HKEY_CURRENT_USER when reading it. When writing it, we only ever write to HKCU. Do you have the value set in the HKLM path?
http://mxr.mozilla.org/mozilla-central/source/toolkit/crashreporter/nsExceptionHandler.cpp#1093

Can you check these registry values:
HKEY_LOCAL_MACHINE\Software\Mozilla\Firefox\Crash Reporter
HKEY_CURRENT_USER\Software\Mozilla\Firefox\Crash Reporter

(this might be a duplicate of bug 580592)

Comment 4

7 years ago
Comment 3 is incomplete. As bug 580592 explains, the values that is actually checked is SubmitCrashReport. A DWORD value of 1 means submit, 0 means do not submit. This SubmitCrashReport value is seached for in these locations (as noted above):

HKEY_LOCAL_MACHINE\Software\Mozilla\Firefox\Crash Reporter
HKEY_CURRENT_USER\Software\Mozilla\Firefox\Crash Reporter
bug 577221 seems to have a summary of how this can happen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 577221
You need to log in before you can comment on or make changes to this bug.