Closed Bug 558726 Opened 10 years ago Closed 10 years ago

|-moz-user-select = "none"| elements missing from innerHTML in latest Minefield

Categories

(Core :: Selection, defect, major)

defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla1.9.3a5
Tracking Status
status1.9.2 --- unaffected
status1.9.1 --- unaffected

People

(Reporter: nirvn.asia, Assigned: mats)

References

Details

(Keywords: regression)

Attachments

(5 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a5pre) Gecko/20100410 Minefield/3.7a5pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a5pre) Gecko/20100410 Minefield/3.7a5pre

Within the last few days (sorry I can't get more precise that this ATM), a change in Minefield resulted in buggy innerHTML content: <select> and <input> elements are missing.

Reproducible: Always

Steps to Reproduce:
1. Open test case
2. Click on the 'display innerHTML' button
Actual Results:  
The alert box displays improper html content found within the <div id="template"> in which the <select> and <input> elements are missing

Expected Results:  
The alert box should display the proper html content found within the <div id="template">
Attached file test case
Attached file testcase2
Regression window:

Works:
http://hg.mozilla.org/mozilla-central/rev/aa360768a319
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100410 Minefield/3.7a5pre ID:20100410132025

Fails:
http://hg.mozilla.org/mozilla-central/rev/1a6aac2558e4
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100410 Minefield/3.7a5pre ID:20100410154225

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=aa360768a319&tochange=1a6aac2558e4
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Linux → All
Version: unspecified → Trunk
When I backed out http://hg.mozilla.org/mozilla-central/rev/2b560e956063 from 3bcd237e52a6 in local build, the problem is gone.
So I presume Bug 166235 cause this problem.
Blocks: 166235
This bug breaks the 'Show Code' button function on userstyles.org .

See http://forums.mozillazine.org/viewtopic.php?p=9148015#p9148015
Taking, since it's my fault really.  Geoff's "v2" patch in bug 166235
tested for 'mIsCopying', which makes it not affect innerHTML.
We have two options:
 1. backout and reopen bug 166235 to implement it correctly
    (in the Selection code).
 2. take the "v2" patch for now

2 is ok with me, roc?
Component: Layout → Selection
QA Contact: layout → selection
Hardware: x86 → All
Summary: elements missing from innerHTML in latest Minefield → |-moz-user-select = "none"| elements missing from innerHTML in latest Minefield
Assignee: nobody → matspal
Fixes this bug, but makes Selection.toString() different from what is copied.
Attachment #438645 - Flags: review?(roc)
Attachment #438645 - Attachment description: Geoff's "v2" version → Geoff's "v2" version (diff -w)
Attached patch mochitest.diffSplinter Review
Comment on attachment 438645 [details] [diff] [review]
Geoff's "v2" version (diff -w)

We should have a test for this regression bug too
Attachment #438645 - Flags: review?(roc) → review+
For landing when the tree opens, together with mochitest.diff
Whiteboard: [needs landing]
Blocks: 558677
http://hg.mozilla.org/mozilla-central/rev/81c83a98798d
http://hg.mozilla.org/mozilla-central/rev/90861e26db38
Status: NEW → RESOLVED
blocking2.0: ? → ---
Closed: 10 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [needs landing]
Target Milestone: --- → mozilla1.9.3a5
You need to log in before you can comment on or make changes to this bug.