Pressing ENTER key for a search from the search box focuses the search on page

RESOLVED DUPLICATE of bug 551434

Status

()

--
major
RESOLVED DUPLICATE of bug 551434
9 years ago
9 years ago

People

(Reporter: mayestera, Unassigned)

Tracking

({regression})

3.6 Branch
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.1.249.1045 Safari/532.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)

When searching from the search box, after pressing the ENTER key, the focus move to the input field of the google search of the loaded page and uses the page's form to search, producing a local page search with an empty search string.

The same in safe-mode and doing the search by using the location bar.

It DOES NOT HAPPEN clicking on the magnifier icon of the search input or doing the same with the Google Toolbar.

Reproducible: Always

Steps to Reproduce:
1. Open http://www.terra.es
2. Search anything with the Firefox Search Form

Actual Results:  
It goes to the Terra results page with an empty search string: http://buscador.terra.es/Default.aspx?ca=s&source=Search&query=

Expected Results:  
The results page for the search string of the search engine selected in the search box.

I've only found the Terra page as an example of this. Happens on all the computers I've try it: Windows XP Professional SP3, Windows Server 2003 Stardard Edition SP2, Windows Vista SP2

It worked fine on Firefox 3.5.9.
Which Firefox search form do you mean? The search bar right next to the location bar? If yes, why do I have to open the given website in step 1 first?
(Reporter)

Comment 2

9 years ago
Yes, is the search bar right next to the location bar.

The given website is an example where it works bad and the bar throws the search to the page instead of going to the results.

In depth example:

1. Open www.terra.es (because is a page where it doesn't work as expected)
2. Select Google as your search motion engine.
3. Type Madrid as example for a search

It goes to 

http://buscador.terra.es/Default.aspx?ca=s&source=Search&query= 

instead of going to

http://www.google.es/search?q=madrid&ie=utf-8&oe=utf-8&aq=t&client=firefox-a&rlz=1R1GGGL_es___ES349

because when pressing the ENTER key, focuses on the form of the page and the enter works on the page instead of the search box.
(Reporter)

Comment 3

9 years ago
I forgot the fourth point below the third point:

4. Press the ENTER Key
Thanks for your reply. I can now reproduce this problem. Can you give another url where it happens? The terra.es page has problems when I try to open it with a nightly build of Firefox. Such one is needed to narrow down the regression range. So if you have another website, please tell us about. Thanks.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: in-testsuite?
Keywords: regression, regressionwindow-wanted
Version: unspecified → 3.6 Branch
(Reporter)

Comment 5

9 years ago
Ok. I don't have any other website where it happens, but if I find one, I'll tell you

Comment 6

9 years ago
I think this is duplicate of Bug 551434  - Toolbar search work not in selected engine but in active page

Comment 7

9 years ago
regression window:
works:
http://hg.mozilla.org/mozilla-central/rev/90d3e6d2cbb9
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2a1pre) Gecko/20090610
Namoroka/3.6a1pre ID:20090610042525

fails:
http://hg.mozilla.org/mozilla-central/rev/4430cae50dad
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2a1pre) Gecko/20090611
Namoroka/3.6a1pre ID:20090611044033

pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=90d3e6d2cbb9&tochange=4430cae50dad

Thre regression range is as same as Bug 551434
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 551434
Flags: in-testsuite?
Keywords: regressionwindow-wanted

Comment 8

9 years ago
Created attachment 438760 [details]
testcase


[STR1]
1. Start Fiirefox with new profile
2. Open testcase
3. Input text in the SearchBar and Press Enter key

[STR2]
1. Start Fiirefox with new profile
2. Open testcase
3. Input text in the LocationBar and Press Enter key

[Actual resalt]
Loading  https://bugzilla.mozilla.org/

[Expected]
Search results are displayed
Alice, I believe you wanted to attach it to bug 551434, right?
You need to log in before you can comment on or make changes to this bug.