Closed Bug 559014 Opened 12 years ago Closed 8 years ago

provide open-with dialog for application/octet-stream

Categories

(MailNews Core :: Attachments, enhancement)

1.9.1 Branch
x86_64
Linux
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 517796

People

(Reporter: harald.dunkel, Unassigned)

References

(Blocks 1 open bug)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100412 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.9) Gecko/20100412 Lightning/1.0b2pre Thunderbird/3.0.4

Some suckers send attachments as "application/octet-stream" instead of "application/pdf", for example. It would be very nice to have an open-with dialog for this, at least on Unix/Linux. The "always do this from now on" option should be disabled for application/octet-stream.

Of course this requires a little bit more responsibility from the user.


Reproducible: Always
Sounds a lot like bug 535634
I am not sure about this. I do not see an "open with" dialog for application/octet-stream attachments at all. The only option I get is to save the file, or to open it. If I click on [open], then the next popup asks me to save the file, too.
Confirm. Thunderbird 2 on Ubuntu karmic offers to open octet-streams with OpenOffice perfectly fine, Thunderbird 3.0.4 on Lucid only offers this 'save' option. This was considered a regression when this happened in 2006, see bug 346332.
(In reply to comment #0)
> It would be very nice to have an open-with dialog for this, at least on Unix/Linux.

As seen in bug 576663 for text type data(xml data) sent with application/octet-stream, and as seen in bug 576663 comment #6 for duplication test of the bug, Tb 3.1 has problem of "Tb 3.1 adds extra .txt, .htm, .xml upon passing data to application by Open, if sent with application/octet-stream".
i.e. This bug is already WORKSFORME in Tb 3.1.

Note:
If .pdf data unfortunately consists of ascii text data only(e.g. bytes for length field consists of binary of us-ascii text), bug 576663 occurs(see bug 576663 comment #6).

> The "always do this from now on" option should be disabled for application/octet-stream.

This is still problem. However, removing entry for it from Tools/Options/Attachments is already possible. So this issue is not critical than before.
Component: General → Attachments
Product: Thunderbird → MailNews Core
QA Contact: general → attachments
Version: unspecified → 1.9.1 Branch
For application/octet-stream & name=xxx.PDF case.

As Tb has relation of application/pdf<->.PDF internally, situation is same as "workaround of bug 576663 is done for .PDF". So, if application/octet-stream & name=xxx.PDF, "Open dialog" is always(for any data type of text or binary) shown by Tb 3.1 with default application for application/pdf pre-selected.
And, even when "always do this from now on" is checked, Tb 3.1 generated mimeTypes.rdf entries for .PDF<->application/pdf.
So, as for application/octet-stream and name=xxx.PDF case, problem of this bug is already fixed by Tb 3.1.
Using 3.1.7 I cannot reproduce this problem anymore. Hopefully its gone?
Feel free to reopen if not a duplicate, but I understand expected results from bug 517796 comment 0 request the same as this bug.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 517796
You need to log in before you can comment on or make changes to this bug.