Last Comment Bug 559052 - Support VP8 / WebM container
: Support VP8 / WebM container
Status: RESOLVED DUPLICATE of bug 566243
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: All All
: -- enhancement with 10 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 566243 566920
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-13 08:08 PDT by Ben Bucksch (:BenB)
Modified: 2010-06-08 19:33 PDT (History)
45 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Ben Bucksch (:BenB) 2010-04-13 08:08:34 PDT
Google bought On2 Technologies recently. They were the creators of VP3.2, which was released patent-free and evolved at Xiph into Ogg Theora. On2 also created VP8, which was more advanced, but not released.
Rumor [1] now has it that Google will release VP8 as open-source, presumably including licensing patents, so VP8 would be as free as Theora.
[1] http://newteevee.com/2010/04/12/google-to-open-source-vp8-for-html5-video/

That'd be great, given that VP8 is a more modern codec than Theora. If Google actually does release it, we should support it. Given that YouTube is owned by Google and YouTube already made experiments with <video> + H.264, there's a good chance that YouTube would support <video> + VP8, which would finally allow us to see YouTube in Mozilla native without Flash. That'd be great.

This is an enhancement request and will track the implementation, in case Google actually releases it. Please no advocacy (one way or the other) "I want this" / "WONTFIX" here, please just use the "vote" feature instead to express that you'd like to see this.
Comment 1 Lars Gunther 2010-05-19 08:48:47 PDT
Will this be the tracking bug for WebM?

http://www.webmproject.org/
Comment 2 Ben Bucksch (:BenB) 2010-05-19 09:09:45 PDT
Yes.

Very cool: Buy software for 130 million US-$, and put it out there as open-source, BSD license with patent grant.
Comment 3 cajbir (:cajbir) 2010-05-19 09:37:58 PDT
See bug 566243 which is the tracking bug to merge the recently announced VP8 support into mozilla-central.
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2010-05-19 13:34:36 PDT

*** This bug has been marked as a duplicate of bug 566243 ***
Comment 5 Ben Bucksch (:BenB) 2010-05-19 14:27:35 PDT
Builds: <http://nightly.mozilla.org/webm/>
YouTube; other browsers: <http://www.webmproject.org/users/>
Comment 6 Chris Pearce (:cpearce) 2010-06-08 19:33:46 PDT

*** This bug has been marked as a duplicate of bug 566243 ***

Note You need to log in before you can comment on or make changes to this bug.