Closed Bug 559432 Opened 10 years ago Closed 7 years ago

###!!! ASSERTION: Cached actor is out of date!: 'static_cast<PluginScriptableObjectChild*>(currentActor) == actor'

Categories

(Core :: Plug-ins, defect, P3)

1.9.2 Branch
x86
Windows XP
defect

Tracking

()

RESOLVED FIXED
mozilla20

People

(Reporter: cbook, Assigned: benjamin)

References

()

Details

(Keywords: assertion)

Attachments

(2 files)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.5pre) Gecko/20100413
Firefox/3.6.5pre

Steps to reproduce:
-> Load the url  
http://n.yam.com/view/mkvideopage.php/20091202455780


###!!! ASSERTION: Cached actor is out of date!: 'static_cast<PluginScriptableObjectChild*>(currentActor) == actor', file c:/work/mozilla/builds/1.9.2/mozilla/dom/plugins/PluginInstanceChild.cpp, line 210
xul!mozilla::plugins::PluginInstanceChild::NPN_GetValue+0x0000000000000124 (c:\work\mozilla\builds\1.9.2\mozilla\dom\plugins\plugininstancechild.cpp, line 290)
xul!mozilla::plugins::child::_getvalue+0x00000000000000D8 (c:\work\mozilla\builds\1.9.2\mozilla\dom\plugins\pluginmodulechild.cpp, line 850)
NPSWF32!NP_Shutdown+0x0000000000002B9D
NPSWF32!FlashPlayer_10_0_45_2_FlashPlayer+0x00000000000EBC6B
I encountered this assertion whilst running a debug build of Minefield.

Changeset 43696:1353f853b17a

Visual Studio 2008 x86 debug build
Windows 7 SDK
Windows 7 64 bit NVidia GeForce 8400M GS
Driver Version 197.16
Flash Version 10.1.53.64

Steps to reproduce
Enable Flash plugin
Enable Direct2D and DirectWrite
Navigate to maps.google.com
Try to use streetview by dragging the yellow figure onto the map.

Assertion in PluginInstanceChild.cpp, Line 235,
NPError
PluginInstanceChild::InternalGetNPObjectForValue(NPNVariable aValue,
                                                 NPObject** aObject)

NS_ASSERTION(static_cast<PluginScriptableObjectChild*>(currentActor) ==
                     actor, "Cached actor is out of date!");

I have attached a minidump exported from Visual Studio.
Visual Studio Crash Dump generated by assertion
I just encountered this exception when running a debug build and having a custom extension automatically surf the internet.

m-c 77594:1f800c226837 (tip from 2011-09-26).

Assertion in PluginInstanceChild.cpp:273

ac_add_options --enable-application=browser
ac_add_options --enable-debug
ac_add_options --enable-tests
ac_add_options --disable-angle
ac_add_options --disable-jemalloc

I have a 110MB dump file (30MB compressed). If interested, I can upload it somewhere. Or, if you tell me what variables you want, I can get those for you.
A dump file would not be helpful, no.
Duplicate of this bug: 718233
If the value of `currentActor` is null, then this assertion is ignorable. We should probably just add a null-check in the assertion itself.
Assignee: nobody → benjamin
Status: NEW → ASSIGNED
Attachment #697556 - Flags: review?(joshmoz)
Priority: -- → P3
Attachment #697556 - Flags: review?(joshmoz) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/8267325d0772

Let's mark this FIXED when it's merged and somebody can reopen if they experience it with a non-null current actor.
https://hg.mozilla.org/mozilla-central/rev/8267325d0772
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
You need to log in before you can comment on or make changes to this bug.