Wear it and Details options do not appear when focusing in Catalan version

VERIFIED FIXED in 2.7

Status

Websites Graveyard
getpersonas.com
VERIFIED FIXED
8 years ago
5 years ago

People

(Reporter: Toni Hermoso Pulido, Assigned: rdoherty)

Tracking

unspecified
x86
All

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Javascript wear it and details options do not appear when focusing over a Persona in getpersonas.com Catalan version.
The problem seems to be related to the translation, concretely to ' (apostrophe character) in some strings. 
I think apostrophes should be automatically escaped from the server side.
(Assignee)

Updated

8 years ago
OS: Linux → All
Target Milestone: --- → 2.7
(Assignee)

Comment 1

8 years ago
Created attachment 439416 [details] [diff] [review]
v1

This should escape anything that comes through a translation.
Attachment #439416 - Flags: review?(janitux)
(Assignee)

Updated

8 years ago
Assignee: nobody → rdoherty
Attachment #439416 - Attachment is patch: true
Attachment #439416 - Attachment mime type: application/octet-stream → text/plain
Comment on attachment 439416 [details] [diff] [review]
v1

actually, json_encode function doesn't escape single quotes, so i think the problem is still there.
What is we use the addslashes function for escaping?
Attachment #439416 - Flags: review?(janitux) → review-

Comment 3

8 years ago
Hello, It seems that the problem is just in the gallery page. If you see the source code, everything is closed between double quotes except these two lines:

     'ie6Warning': 'Actualitzeu el vostre navegador per poder obtenir el millor d'aquest lloc web. <a href="%LINK%">Baixeu el Firefox gratuïtament</a>.',

      $("#header").ie6Warning({"message":'<div id="ie6">Actualitzeu el vostre navegador per poder obtenir el millor d'aquest lloc web. <a href="%LINK%">Baixeu el Firefox gratuïtament</a>.</div>'});

what happens is that "d'aquest" breaks the javascript string.

We have changed "d'aquest" with "d\'aquests" in verbatim. So please could you commit the changes to stage in order to test if this is enough.
(Reporter)

Comment 5

8 years ago
Working now. rdoherty, janitux. Site is working for Catalan. Either we keep this workaround or let's escape it at the server level (we would revert the translation). You decide. In any case, if a working version could be pushed to production the sooner the better would be wonderful.
(Assignee)

Comment 6

8 years ago
Quim: we have a fix incoming, so we won't need translations to be changed.

Patricio: Not escaping single quotes is fine b/c the strings will be in double quotes, so we don't need to escape them (afaik).
(Reporter)

Comment 7

8 years ago
I've committed back to the non-escaped translated version. http://viewvc.svn.mozilla.org/vc/projects/getpersonas.com/trunk/server/locale/ca/LC_MESSAGES/messages.po?r1=66186&r2=66406 May you try your fix?
(Assignee)

Comment 8

8 years ago
(In reply to comment #7)
> I've committed back to the non-escaped translated version.
> http://viewvc.svn.mozilla.org/vc/projects/getpersonas.com/trunk/server/locale/ca/LC_MESSAGES/messages.po?r1=66186&r2=66406
> May you try your fix?

Yep, we will.
(Reporter)

Comment 9

8 years ago
Any news? If you think this will not be fixed soon, we may apply our l10n workaround and commit it to production this upcoming week.
(Reporter)

Comment 10

8 years ago
Sorry guys, if this cannot be solved tomorrow, on Tuesday I would revert back to the workaround version and I would ask for pushing to production this last commit. It's almost one month since this report and Catalan users have not enjoyed a fully working getpersonas.com site. If we wait more, there could be another site already...

Thanks!
(Assignee)

Comment 11

8 years ago
Patricio: did you see comment #6? I'm pretty sure my fix works. We can push it live tmrw if so.

Comment 12

8 years ago
I see that stage and also getpersonas.com is not working yet? is there any problem else?

http://personas.stage.mozilla.com/ca/
http://www.getpersonas.com/ca/
(Assignee)

Comment 13

8 years ago
r67359

I'm sure my patch works, committing to stage for testing.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Now you don't see 'Wear it' & 'Details' buttons on any locale , even en-US.
Reopening...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 15

8 years ago
(In reply to comment #14)
> Now you don't see 'Wear it' & 'Details' buttons on any locale , even en-US.
> Reopening...

oops, r67370
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
'Wear it' & 'Details' button appear on all gallery pages (http://personas.stage.mozilla.com/ca/gallery/All/Recent)
but do not appear on personas details page (http://personas.stage.mozilla.com/ca/persona/33526) & home page.
Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 17

8 years ago
This is why we have QA! :)

r67378 should fix this permanently.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 18

8 years ago
Wonderful! :) It seems to work for me in stage. However, I notice that when focusing over a Persona in stage it does not change in my browser (no matter the locale version) Is this normal?
If everything were OK I would ask these last modifications and last ca translation to be pushed to production site.
(Assignee)

Comment 19

8 years ago
(In reply to comment #18)
> Wonderful! :) It seems to work for me in stage. However, I notice that when
> focusing over a Persona in stage it does not change in my browser (no matter
> the locale version) Is this normal?

You'll need to add personas.stage.mozilla.com to your add-ons install whitelist for previews to happen.
Verified, FIXED.
Status: RESOLVED → VERIFIED

Comment 21

8 years ago
Hi,

Why http://www.getpersonas.com/ca/ is not working yet ? 

This bug took 1 mounth to get fixed and one month later it still have problems in production !

Catalan users will think that getpersonas will never work.

I'm sorry but I'm getting very ungry with this, we have worked a lot to translate getpersonas in very few time, and after all the work, two months later it doesn't work yet.

****
it says verified fixed, I'll believe that.  I think the next update for getpersonas.com is scheduled for Thursday so if it isn't working by friday/saturday then something might be amiss.
(Assignee)

Comment 23

8 years ago
Quim, we're pushing Thursday. It is fixed on stage.
(Reporter)

Comment 24

8 years ago
(In reply to comment #23)
> Quim, we're pushing Thursday. It is fixed on stage.

Did you push? I assured to clean my cache, but I don't see changes applied to production yet.
(Assignee)

Comment 25

8 years ago
(In reply to comment #24)
> Did you push? I assured to clean my cache, but I don't see changes applied to
> production yet.

Push got bumped to Tuesday https://bugzilla.mozilla.org/show_bug.cgi?id=571140
Component: getpersonas.com → getpersonas.com
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.