Closed Bug 559663 Opened 10 years ago Closed 7 years ago

Create new Talos test suite: Measure IOPs instead of time for tracking startup improvements

Categories

(Testing :: Talos, defect, P5)

x86
Linux
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 770317

People

(Reporter: taras.mozilla, Unassigned)

References

Details

(Whiteboard: [talos])

Mac(dtrace)/Windows(xperf)/Linux(systemtap+perf?) all provide ways to capture read syscalls + page faults backed by files.
In some cases they even annotate them with backtraces that lead to that io operation. 
These IOPS correlate exactly to startup time, but don't vary as much. IOPS can be measured reliably in a VM. In general they are a much better metric than time.
We need hook into each of the tracing frameworks, produce uniform results for all platforms and produce a graph for every build. It would be nice to have pretty graphs to go with the data, something like http://people.mozilla.com/~tglek/startup/systemtap_graphs/visualize.html?#stock.io.html
Priority: -- → P5
Whiteboard: [talos]
Summary: Measure IOPs instead of time for tracking startup improvements → Create new Talos test suite: Measure IOPs instead of time for tracking startup improvements
Moving this bug to Testing:General for suite development, as requested by bmoss, ctalbert. 

Once this new suite is developed, please file a separate bug in
mozilla.org/ReleaseEngineering to enable running the new suite on builds
automatically.
Component: Release Engineering → General
Product: mozilla.org → Testing
QA Contact: release → general
Version: other → unspecified
Moving to Talos component.
Component: General → Talos
Blocks: 501563
:taras, is this resolved by measuring the xperf counters?  We don't run tests in vm's, so measuring IOPs with talos is not an option.
(In reply to Joel Maher (:jmaher) from comment #3)
> :taras, is this resolved by measuring the xperf counters?  We don't run
> tests in vm's, so measuring IOPs with talos is not an option.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 770317
You need to log in before you can comment on or make changes to this bug.