Last Comment Bug 559746 - add a11y mochitests for <input type="tel">
: add a11y mochitests for <input type="tel">
Status: RESOLVED FIXED
[good first bug][mentor=surkov.alexan...
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla14
Assigned To: Max Li [:maxli]
:
Mentors:
http://dev.w3.org/html5/spec/forms.ht...
Depends on: 558063 557620 559766
Blocks: html5a11y
  Show dependency treegraph
 
Reported: 2010-04-15 22:43 PDT by alexander :surkov
Modified: 2012-04-05 10:45 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (3.85 KB, patch)
2012-04-03 19:16 PDT, Max Li [:maxli]
surkov.alexander: review+
Details | Diff | Splinter Review

Description alexander :surkov 2010-04-15 22:43:09 PDT
It's going to be autocomplete text field. We should expose it as COMBOBOX role and make sure STATE_INVALID is managed properly.
Comment 1 alexander :surkov 2010-04-15 23:53:13 PDT
Autocomplete stuffs should be covered by bug 559766
Comment 2 alexander :surkov 2012-02-08 04:35:53 PST
It should be exposed as text entry with autocomplete state now. So all we should do is to add mochitest (add to states/test_inputs at autocomplete testing part and to tree/test_txtctrl.html).
Comment 3 Max Li [:maxli] 2012-04-03 19:16:37 PDT
Created attachment 612060 [details] [diff] [review]
Patch v1
Comment 4 alexander :surkov 2012-04-03 22:40:47 PDT
Comment on attachment 612060 [details] [diff] [review]
Patch v1

Review of attachment 612060 [details] [diff] [review]:
-----------------------------------------------------------------

I'll fix those before landing, thank you!

::: accessible/tests/mochitest/states/test_inputs.html
@@ +160,5 @@
> +  <a target="_blank"
> +     href="https://bugzilla.mozilla.org/show_bug.cgi?id=559746"
> +     title="add a11y mochitests for <input type='tel'>">
> +    Mozilla Bug 559746
> +  </a>

well, I think it's not necessary since it was just mochitest

::: accessible/tests/mochitest/tree/test_txtctrl.html
@@ +117,5 @@
> +  <a target="_blank"
> +     href="https://bugzilla.mozilla.org/show_bug.cgi?id=559746"
> +     title="add a11y mochitests for <input type='tel'>">
> +    Mozilla Bug 559746
> +  </a>

same

Note You need to log in before you can comment on or make changes to this bug.