Closed Bug 560202 Opened 12 years ago Closed 12 years ago

[Regression] Add bookmark dialog, Folder selection treeview doesn't work properly

Categories

(Firefox :: Bookmarks & History, defect)

defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: BenB, Assigned: asaf)

References

Details

(Keywords: regression)

Note: This is *not* easily reproducible, it apparently happens only sometimes.
Also note that I have many several thousand bookmarks in hundreds of folders.

Reproduction:
1. Go to website (which is not yet bookmarked)
2. Click star icon on the right of the URLbar, twice. => Bookmark dialog
3. Click down arrow next to the folder dropdown, to see all bookmark
   folders in a treeview (hierarchical widget).
4. Open some folders using the twisty.

Actual result:
The twisty for the folder is in opened state (down arrow), but no folders appear underneath it, although there are folders. Re-closing and re-opening does not help. Same happens for other folders.
If you close the bookmark dialog (via cancel) and re-open it, the wierd state persists.

Expected result:
All existing folders shown.

Regression:
This is a new bug which appeared recently (after March 1).
A recent post on m.d.a.firefox suggests that somebody else saw it as well.

Importance:
This is a frequently used action and core browser functionality.
=> Major
this regressed within Alpha 2 -> 3. delta of bugfixes: http://arm.in/efy
could be related to bug 556342
Blocks: 543444
blocking2.0: --- → ?
BenB: Do you have a tree? If so, would you mind testing the patch from bug 553334?
I can't reliably reproduce the issue anyways. When I tried it without the fix, I had to open the bookmarks dialog 2 times, and lots of open/close in the 1. invocation, then the bug immediately appeared in the 2. invocation. So, it's rather random.

But I couldn't reproduce the bug with the patch applied.
Depends on: 553334
(In reply to comment #3)
This Issue is now WFM using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a6pre) Gecko/20100620 Minefield/3.7a6pre ID:20100620053841

Progression Range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6dbc5341b490&tochange=b219912edfec what includes the Checkin of Bug 553334.
Assignee: nobody → mano
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.