Closed Bug 560715 Opened 10 years ago Closed 10 years ago

Windows trunk builds failing due to: storagecomps.dll : fatal error LNK1120: 2 unresolved externals

Categories

(Firefox Build System :: General, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9.3a5

People

(Reporter: standard8, Assigned: neil)

References

Details

Attachments

(1 file)

Trunk builds of comm-central are failing with:

storage_s.lib(mozStorageAsyncStatementExecution.obj) : error LNK2019: unresolved external symbol "__declspec(dllimport) public: static class mozilla::TimeStamp __cdecl mozilla::TimeStamp::Now(void)" (__imp_?Now@TimeStamp@mozilla@@SA?AV12@XZ) referenced in function "private: unsigned int __thiscall mozilla::storage::AsyncExecuteStatements::buildAndNotifyResults(struct sqlite3_stmt *)" (?buildAndNotifyResults@AsyncExecuteStatements@storage@mozilla@@AAEIPAUsqlite3_stmt@@@Z)
storage_s.lib(mozStorageAsyncStatementExecution.obj) : error LNK2019: unresolved external symbol "__declspec(dllimport) public: static class mozilla::TimeDuration __cdecl mozilla::TimeDuration::FromMilliseconds(int)" (__imp_?FromMilliseconds@TimeDuration@mozilla@@SA?AV12@H@Z) referenced in function "private: __thiscall mozilla::storage::AsyncExecuteStatements::AsyncExecuteStatements(class nsTArray<class mozilla::storage::StatementData> &,class mozilla::storage::Connection *,class mozIStorageStatementCallback *)" (??0AsyncExecuteStatements@storage@mozilla@@AAE@AAV?$nsTArray@VStatementData@storage@mozilla@@@@PAVConnection@12@PAVmozIStorageStatementCallback@@@Z)
storagecomps.dll : fatal error LNK1120: 2 unresolved externals

Possibly as a result of bug 480735.

vlad took a look at a possible fix, but didn't get any improvement.

I'm confused why this isn't happening on the other platforms. I've therefore triggered a clobber of all the Windows check builders to see if that resolves it.
Neil thinks this is because there are some missing dlldeps.cpp changes from an earlier bug - see bug 506959 comment 13.

If anyone can try and reproduce and test a fix, please do. Otherwise I'll have to take a look tomorrow.
Blocks: 506959
It's not due to either of those bugs, but as commented, dlldeps.cpp is missing any reference to TimeStamp stuff at all -- so none of the TimeStamp methods are being exported.  The storage change to use TimeStamp is just exposing this.  (dlldeps seems incredibly fragile!)
No longer blocks: 480735, 506959
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #440437 - Flags: review?(benjamin)
OS: Mac OS X → Windows XP
Product: MailNews Core → Core
QA Contact: build-config → build-config
blocking2.0: --- → ?
Attachment #440437 - Flags: review?(benjamin) → review+
(In reply to comment #3)
> Created an attachment (id=440437) [details]

Pushed as: http://hg.mozilla.org/mozilla-central/rev/8ff5e04c0566
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a5
blocking2.0: ? → ---
this patch did not actually fix the bug :/
Status: RESOLVED → REOPENED
blocking2.0: --- → ?
Resolution: FIXED → ---
Target Milestone: mozilla1.9.3a5 → ---
Comment on attachment 440437 [details] [diff] [review]
Bustage fix
[Checkin: See comment 4+7]


http://hg.mozilla.org/mozilla-central/rev/ed54089cce34
Attachment #440437 - Attachment description: Bustage fix → Bustage fix [Checkin: See comment 4+7]
Status: REOPENED → RESOLVED
blocking2.0: ? → ---
Closed: 10 years ago10 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a5
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.