Closed Bug 560957 Opened 11 years ago Closed 11 years ago

Talos profiles, plugins, etc. should be fetched via http

Categories

(Release Engineering :: General, defect, P2)

x86
Linux
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: catlee, Assigned: catlee)

References

Details

(Whiteboard: [talos])

Attachments

(2 files)

Ideally from stage, or some public location.  FileDownload is slow, gets stuck, and smells funny too.
FileDownload ate my baby!
Priority: -- → P5
More stuck builds because of FileDownload eating babies.

fox2mike sez that it should be easy to set up a pull from cruncher onto stage.  We already have rsyncd set up on cruncher.

1) Alice, can you update your scripts on cruncher to put the files into /var/www/html/talos_profiles.

2) Also, figure out where on stage they should go.

Next, we can file an IT bug to rsync from cruncher::talos_profiles to wherever we'd like on stage.
Priority: P5 → P3
Scripts now updated to mv dirty profiles to /var/www/html/talos_profiles after they are updated nightly.
Duplicate of this bug: 559667
We need a place on ftp to put these things.  Any suggestions?
Assignee: nobody → catlee
Priority: P3 → P2
Summary: Talos profiles should be fetched via http → Talos profiles, plugins, etc. should be fetched via http
(In reply to comment #5)
> We need a place on ftp to put these things.  Any suggestions?

http://ftp.mozilla.org/pub/mozilla.org/firefox/{others,extra,tools,etc} ?

Are these stuff that we (firefox) only use?
(In reply to comment #5)
> We need a place on ftp to put these things.  Any suggestions?

We settled on http://build.mozilla.org/talos
Comment on attachment 447926 [details] [diff] [review]
Switch most FileDownloads to DownloadFile in TalosFactory

Looks good to me!
Attachment #447926 - Flags: review?(bhearsum) → review+
Comment on attachment 448406 [details] [diff] [review]
Set support_url_base in buildbot configs to http://build.mozilla.org/talos

Seems fine
Attachment #448406 - Flags: review?(bhearsum) → review+
Comment on attachment 447926 [details] [diff] [review]
Switch most FileDownloads to DownloadFile in TalosFactory

changeset:   755:8b1380cbf092
Attachment #447926 - Flags: checked-in+
Comment on attachment 448406 [details] [diff] [review]
Set support_url_base in buildbot configs to http://build.mozilla.org/talos

changeset:   2466:dc300ccfeaa1
Attachment #448406 - Flags: checked-in+
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.