Default action for doubleclicking the collapsed thread in Message list should be "Open message in conversation"

RESOLVED DUPLICATE of bug 522837

Status

Thunderbird
Folder and Message Lists
--
enhancement
RESOLVED DUPLICATE of bug 522837
8 years ago
7 years ago

People

(Reporter: Valery Kondakoff, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.5pre) Gecko/20100422 Lanikai/3.1b2pre

When you click (or hit enter) on a collapsed thread in Message list it defaults to 'Open message in new Tab' command and open several messages in separate tabs. I'm pretty sure, double-click (or Enter) on a _collapsed_ thread should defaults to 'Open message in conversation' instead.

Reproducible: Always
Severity: normal → enhancement
Component: General → Folder and Message Lists
QA Contact: general → folders-message-lists

Comment 1

7 years ago
I Agree. This is also the behavior on Mac. Not only should it default to Open In Conversation (or at least have a preference setting for it), when the collapsed thread row is selected, Open In Conversation is grayed out in the Message menu; you can't press CMD+SHIFT+O either. I would love if this feature was more accessible!

Comment 2

7 years ago
This is probably a duplicate of bug 550775 (or dependent on it).
(In reply to comment #2)
> This is probably a duplicate of bug 550775 (or dependent on it).

Dup :-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 550775
Bug 550775 seeks to implement ways of opening multiple selected messages in conversation, whereas this bug wants to use that feature as the default action for double-clicking on a collapsed thread. That's not quite the same thing. So the two bugs are not duplicates, but this bug depends on bug 550775 -> reopening, and setting dependency.
Status: RESOLVED → REOPENED
Depends on: 550775
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → All
Resolution: DUPLICATE → ---
Summary: Double-clicking the collapsed thread in Message list should defaults to Open message in conversation → Default action for doubleclicking the collapsed thread in Message list should be "Open message in conversation"

Updated

7 years ago
Duplicate of this bug: 651516

Comment 6

7 years ago
CF Bug 651516 comment #7
It refers to windows opening instead of tabs opening, but is same problem:

Packing my desk top with several layers of windows is sufficiently unfriendly
that there needs to be a friendly way to not do that.  As mentioned, if you
were simply to do separate defaults based on whether or not tab views were
enabled, you would likely have something reasonable enough.  But because the
default presumes that everybody uses tab views, there needs to be some way
that can be found by non-guru users to make it usable.

So, it is a documentation bug that it is this difficult to figure out
how to fix the problem at all (just index the "config editor" configurables
in some way) and it is a functionality bug that the open-a-million-windows
is the default for folks who open emails in separate windows.

Updated

7 years ago
Duplicate of this bug: 522837

Comment 8

7 years ago
Jim, we usually keep the older bug, unless there is much better information or patches in the new bug. In this case, there's even a workaround in the other bug.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 522837
You need to log in before you can comment on or make changes to this bug.