Last Comment Bug 56121 - <a onClick> types of links don't look like links
: <a onClick> types of links don't look like links
Status: VERIFIED INVALID
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: P3 minor (vote)
: ---
Assigned To: clayton
: Loco
Mentors:
http://www.e-shuppan.com/Html/Main/Fo...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-11 10:59 PDT by Tobias Burnus
Modified: 2001-09-05 10:49 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
HTML file which shows a onClick and a href link (1.06 KB, text/html)
2000-10-11 11:16 PDT, Tobias Burnus
no flags Details

Description Tobias Burnus 2000-10-11 10:59:05 PDT
This is with 2000-10-10-21/Linux (Mozilla nightly).
If a link (<a> only contains a onClick="" and not a href="foo" then it looks
like a normal <span> i.e. as if there where no link. (This includes colour,
underlining and cursor.)
Netscape 4.75/Linux shows the same, but it doesn't (seem) to support onClick.

"12.2 The A element" is not clear how to handle this case. I think it makes
sense to support this if there is onClick (since it acts like a link in this
case). Opera 4.0b4/Linux handles it the very same as Mozilla does presently.

I would either see this fixed or marked as invalid (both after some discussion).
Comment 1 Tobias Burnus 2000-10-11 11:16:12 PDT
Created attachment 16782 [details]
HTML file which shows a onClick and a href link
Comment 2 Heikki Toivonen (remove -bugzilla when emailing directly) 2000-10-11 11:28:43 PDT
IE 5 and NN 4.7 don't recognize <a onClick as a link. And it isn't, really. The
presence of onClick does not make it a link. It can act like a link with certain
kinds of JavaScript, but in the arbitrary case it would not even act like a link.

Marking this INVALID.
Comment 3 Tobias Burnus 2000-10-11 11:47:09 PDT
[Drop in from the mid-air collision:]
Unlike the HTML 4.01 specification the CSS 2 specification states in "5.11.2 The
link pseudo-classes: :link and :visited":
"The document language determines which elements are hyperlink source anchors.
For example, in HTML 4.0, the link pseudo-classes apply to A elements with an
'href' attribute."

Reading this would make it INVALID, since I think that is not that clear that
onClick shouldn't act like href I wrote to www-styles@w3.org for
discussion/verification (subject=":links and HTML" if you search).
Comment 4 Loco 2000-10-12 14:27:27 PDT
Marking VERIFIED.  Tobias, if the reply from W3 is that it should look like a 
link, just reopen this.  Thanks.  -d
Comment 5 Heikki Toivonen (remove -bugzilla when emailing directly) 2001-09-05 10:49:06 PDT
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.

Note You need to log in before you can comment on or make changes to this bug.