[Promo module]Button extends to the next tab in French locale

VERIFIED FIXED in 5.10

Status

defect
VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: krupa.mozbugs, Assigned: gerard-majax)

Tracking

unspecified
5.10
x86
macOS

Details

(Whiteboard: [z][regression], )

Attachments

(1 attachment)

Reporter

Description

9 years ago
Posted image screenshot
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

steps to reproduce:
1.Go to https://preview.addons.mozilla.org/z/fr/firefox/#t-social
2.Notice the left hand side of the promo module.

observed behavior:
see screenshot
Assignee: nobody → craigcook.bugz
This is tangentially related to bug 560590. The button text is simply too long and buttons aren't designed to wrap. Possible solutions, in my order of recommendation:

1. Devise a shorter equivalent translation for the button label (would need help from French localizers).

2. Rebuild buttons to allow wrapping text (related to bug 560590, still awaiting final decision).

3. Exclude EULA add-ons from the promo box since those add-ons have long buttons (just evades this specific problem without really solving it, and the buttons will still be superlong when they appear in other areas).

4. Hide the column overflow (this would truncate wide buttons and make them unreadable, probably a bad idea).
Is there a way to hide the overflow for non "active" panes of the carousel?
(In reply to comment #2)
> Is there a way to hide the overflow for non "active" panes of the carousel?

That would prevent the offscreen button from jutting into the active viewing area, but when that pane is active itself the same button goes outside the viewing area and gets cut off. Whenever a button is wider than its column it invades the column next to it.

So just clipping or hiding the non-active panes doesn't actually solve the real problem. It's really down to either less text per button or buttons that allow the text to wrap.
CCing Alexandre.  I think this is caused by this button label:

Continuer vers les téléchargements →

How can we make this shorter?
Assignee

Comment 5

9 years ago
If it's length, we might try something like « Aller aux téléchargements ». I just commited a change to z-messages.po to do this, r66475.
I think that works, thanks.  Further discussion for these buttons is happening in the last comments of bug 560590
Assignee: craigcook.bugz → alexandrelissy
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Assignee

Comment 7

9 years ago
Okay, let me know if you need any other changes
Reporter

Comment 8

9 years ago
This looks much better now.Thanks!
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.