Closed Bug 561387 Opened 12 years ago Closed 11 years ago

Investigate Null CrashReports II

Categories

(Socorro :: General, task)

x86
Windows XP
task
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 564196

People

(Reporter: cbook, Assigned: laura)

References

Details

Seems http://crash-stats.mozilla.com/report/index/140cd1f6-81d1-4afe-bea4-179942100422 and http://crash-stats.mozilla.com/report/index/dabe0484-7573-4ec9-af6e-a06592100423 are broken and no usable data is generated here. - Not even a OS

The Reporter in @qa told me as steps to reproduce:
09:16 < satdav> I was on bubbleshooter.net playing the game and on irc vie chatzilla and it just crashed
we get about 100k \N signatures a day.

we could turn this into a bug about bubbleshooter null signature crashes

awk -F\t '$1 ~ /\N/ {print $2}' 201004*  | grep bubbleshoot | sort | uniq -c | sort -nr
  19 http://bubbleshooter.net/
  12 http://www.bubbleshooter.net/
   3 http://www.bubbleshooter.net/games/001_bubble_shooter.swf
   2 http://www.bubbleshooter.cz/1-bubble-shooter
   1 http://www.spieleforfree.de/bubbleshooter.htm
   1 http://www.puffgames.com/bubbleshooter/
   1 http://www.notdoppler.com/bubbleshooter.php
   1 http://www.bubbleshooter.net/game8.php
   1 http://www.bubbleshooter-game.de/
   1 http://www.andkon.com/arcade/tetris/bubbleshooter/bubbleshooter.swf
   1 http://puffgames.com/bubbleshooter/
   1 http://notdoppler.com/bubbleshooter.php
   1 http://fliperama.terra.com.br/jogos_online/jogos_de_raciocinio/bubbleshooter.php
   1 http://fliperama.terra.com.br/jogos-de-raciocinio/bubbleshooter.php

or we could start trying to figure out the url's most frequently associated with null signatures, or we could do both ;-)  

Here are overall top sites with null sigs

3410 http://chatroulette.com/
2085 http://apps.facebook.com/onthefarm/index.php
1783 http://apps.facebook.com/onthefarm/index.php?ref=tab
1586 about:blank
 838 http://www.chatroulette.com/
 764 http://apps.facebook.com/onthefarm/index.php?ref=exchangeskip
 637 http://www.facebook.com/?ref=home
 636 http://fb-3.farmville.com/xd_receiver.htm
 623 http://fb-2.farmville.com/xd_receiver.htm
 592 http://apps.facebook.com/texas_holdem/index.php?src_track_str=Poker+FB+Bookmark+Other+%25ACTION%25+o%3ABookmark%3A2009-03-11&ref=bookmarks
 591 http://apps.facebook.com/onthefarm/index.php?ref=rewardPage
 562 http://fb-1.farmville.com/xd_receiver.htm
 548 http://fb-0.farmville.com/xd_receiver.htm
 489 http://apps.facebook.com/onthefarm/index.php?gifterror=notfound
 474 http://chatroulette.com/standard.html


the last big chunk of null crashes the we diagnosed was anti-virus stuff IIRC.  This time it might turn up something more flash related.  We could also look at null crash differences between OOPP builds and non-OOPP to ensure we haven't tweaked the crash reporting system in a way that creates more null sigs.

which way should we take this bug or bugs?
Summary: Broken CrashReport → Investigate Null CrashReports II
the reporter in this case had a outdated flash version and the boubleshooter site/game is a flash game, fwiw
I think Bubbleshooter is way too specific. Let's see if we can find a reproducible test case for generating a null crash sig with Flash (in windows I assume).  It looks like facebook/farmville or chatroulette may be a good place to start and if so, we can see if OOPP can help with it.
We've had plenty of Flash crashes in the past that corrupt the heap so badly that we can't write out a valid minidump. I don't think there's much we can do about that aside from ship OOPP.
From CrashKill meeting: make it easy to search for these and see user comments associated as they are often telling.
Target Milestone: --- → 2.0
In the current UI for search results and top crashers, we use a special code out of band with the signature parameter to control this.

This extra param is missing_sig... so something like:
missing_sig=None
missing_sig=Empty
I think these constants are in http://code.google.com/p/socorro/source/browse/trunk/webapp-php/application/libraries/crash.php (code.google is down right now)
(In reply to comment #6)
> From CrashKill meeting: make it easy to search for these and see user comments
> associated as they are often telling.

This might help a little - Bug 552088 - crash reports with email addresses but no comment don't all bubble up to the top of the "comments" tab.
Depends on: 552088
bp-0f7fbce5-30af-4309-8e5c-53ce92100520 has a processor note of "value too long for type character varying(255)" and signature 
nsXBLPrototypeHandler::ConstructPrototype(nsIContent*, unsigned short const*, unsigned short const*, unsigned short const*, unsigned short const*, unsigned short const*, unsigned short const*, unsigned short const*, unsigned short const*, unsigned short const*, unsigned short const*, unsigned short const*, unsigned short const*)

but summarizes as (null signature) in topcrash list
Blocks: 552909
(In reply to comment #9)
> bp-0f7fbce5-30af-4309-8e5c-53ce92100520 has a processor note of "value too long
> for type character varying(255)" and signature 
> nsXBLPrototypeHandler::ConstructPrototype(nsIContent*, unsigned short const*,
> unsigned short const*, unsigned short const*, unsigned short const*, unsigned
> short const*, unsigned short const*, unsigned short const*, unsigned short
> const*, unsigned short const*, unsigned short const*, unsigned short const*,
> unsigned short const*)
> 
> but summarizes as (null signature) in topcrash list

Austin, Laura is this tracked in socorro ?
I think I might be able to guess why this is happening.   That signature is 332 characters long and therefore won't fit in the column (signature character varying(255)).

Lars, do we want to do something like truncate excessively long signatures?  Will the problem go away when we hook the front end up to HBase anyway?
hbase itself doesn't have a character limit on the values, so it wouldn't be a problem on that side.
Bug 564196 was supposed to have truncated signatures to fit in the database.
The code fix for truncating signatures was targeted for 1.7.  I've verified that the code exists in that release.  I can see that 1.7 was pushed to production on June 10th (Bug 571228).  The offending crash has a date of May 20th.
Assignee: nobody → laura
lars: should this be closed?
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 564196
(In reply to comment #6)
> From CrashKill meeting: make it easy to search for these and see user
> comments associated as they are often telling.

This is still something we should do, I think, but it might make sense to create a separate, clearly described bug for that.
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.