Closed Bug 564196 Opened 12 years ago Closed 12 years ago

Truncate signatures which are too long so that they don't say (no signature)

Categories

(Socorro :: General, task)

x86
Windows 7
task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: benjamin, Assigned: lars)

References

Details

http://crash-stats.mozilla.com/report/index/07e2e1d6-d49e-412d-88af-8aa942100506

The signature is too long. I would be perfectly fine with truncating it at 255/254 characters: it has more than enough data to be unique.
that was simple...

      if len(processor_notes) > 255:
        processor_notes = '%s...' % processor_notes[:252]

this will appear in 1.7
Assignee: nobody → lars
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.7
Does that truncate the signature, or the processor_notes field?
eh, wrong paste buffer.  That was the code fragment used as the template for the signature change.  If I had copied the right code, it would have looked like this:

if len(reportRow['signature']) > 255:
  reportRow['signature'] = '%s...' % reportRow['signature'][:252]
bugzilla doesn't support 256 character long signatures. please try to truncate closer to 128 or 200
Blocks: 587142
Duplicate of this bug: 561387
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.