All users were logged out of Bugzilla on October 13th, 2018

Only upload breakpad symbols to FTP

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
9 years ago
8 months ago

People

(Reporter: catlee, Assigned: catlee)

Tracking

Trunk
x86
All
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
A large part of our current bandwidth issues are caused by downloading large crashreporter-symbols.zip files, which contain not only the breakpad symbols but also the platform-specific object files.

Talos and Unittests only need the breakpad symbols to generate stack traces on crash.  It's my understanding that the debug build assertion stack trace generator is busted, and could also make use of the breakpad symbols.

This patch results in 'make buildsymbols' creating two zip files:

*-crashreporter-symbols.zip: gets uploaded to FTP, and then downloaded by unittest / talos boxes to generate stack traces on crash

*-crashreporter-symbols-full.zip: gets uploaded to the symbol server

'make uploadsymbols' will upload the crashreporter-symbols-full.zip file to the symbol server (for nightly builds)

'make upload' will upload just the crashreporter-symbols.zip file to FTP.
OS: Linux → All
(Assignee)

Comment 1

9 years ago
Created attachment 441099 [details] [diff] [review]
Only upload breakpad symbols to FTP
Attachment #441099 - Flags: review?
(Assignee)

Updated

9 years ago
Attachment #441099 - Flags: review? → review?(benjamin)

Comment 2

9 years ago
Comment on attachment 441099 [details] [diff] [review]
Only upload breakpad symbols to FTP

This is fine as a temporary measure. As a more permanent solution, at least on Windows and probably Linux we should upload the -full package to FTP. Developers do use those symbols for local debugging.
Attachment #441099 - Flags: review?(benjamin) → review+
http://hg.mozilla.org/mozilla-central/rev/bd5f3bf5c511
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Assignee: nobody → catlee
Blocks: 555794
Priority: -- → P2
Duplicate of this bug: 551189
Blocks: 603154

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.