Closed Bug 561982 Opened 10 years ago Closed 10 years ago

Broken extension status button in list view when clicking 'Disable' or 'Enable' button

Categories

(Toolkit :: Add-ons Manager, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla1.9.3a5

People

(Reporter: whimboo, Assigned: Unfocused)

References

Details

(Whiteboard: [rewrite])

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100426 Minefield/3.7a5pre

When you disable an installed extension via the list view or the details view, the list view will contain a broken status button for that extension. See attachment 435474 [details].

1. Install an extension and restart Firefox
2. Disable the newly installed extension

Can we get this fixed before Friday so testers will not run into this highly visible problem during the testday?
Also happens when you try to enable an extensions.
Summary: Broken extension status button in list view when clicking 'Disable' button → Broken extension status button in list view when clicking 'Disable' or 'Enable' button
Priority: -- → P1
http://hg.mozilla.org/projects/addonsmgr/rev/991b7daba3cc
Whiteboard: [rewrite] → [rewrite][fixed-in-addonsmgr][needs-review]
That works now. Thanks.
Assignee: nobody → bmcbride
Status: NEW → ASSIGNED
Blocks: 562679
r=me based on the landed changeset
Whiteboard: [rewrite][fixed-in-addonsmgr][needs-review] → [rewrite][fixed-in-addonsmgr][needs-landing]
Landed as a part of http://hg.mozilla.org/mozilla-central/rev/3c6862a3b12f
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Whiteboard: [rewrite][fixed-in-addonsmgr][needs-landing] → [rewrite]
Target Milestone: --- → mozilla1.9.3a5
Verified with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a5pre) Gecko/20100514 Minefield/3.7a5pre ID:20100514030623

Would be a part of a Litmus test. How much of it would be doable by an automated test?
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
Flags: in-litmus?
Flags: in-testsuite? → in-testsuite-
Flags: in-litmus? → in-litmus?(vlad.maniac)
Existing Litmus test has been updated:
https://litmus.mozilla.org/show_test.cgi?id=10150
Flags: in-litmus?(vlad.maniac) → in-litmus+
You need to log in before you can comment on or make changes to this bug.