Land new Add-ons Manager on trunk

VERIFIED FIXED in mozilla1.9.3a5

Status

()

Toolkit
Add-ons Manager
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: whimboo, Assigned: mossop)

Tracking

Trunk
mozilla1.9.3a5
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rewrite])

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Once all remaining P1 blockers (which I have added to the dependency list are done, we have to finally land the new Add-ons Manager code on trunk.

Dave, I believe you will work on that. I will set you as assignee for now.
(Reporter)

Updated

8 years ago
Blocks: 562682
(Assignee)

Comment 1

8 years ago
This is now landed, we have a perf regression on OSX that I will be looking into over the next couple of days and then backing out if I don't resolve it.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(In reply to comment #1)
> This is now landed, we have a perf regression on OSX that I will be looking
> into over the next couple of days and then backing out if I don't resolve it.

Pretty smooth landing, for the size of it. Not to suggest the perf regression is unimportant, but it seems we gain more than we lose by keeping it on trunk, and keeping the perf regression to a followup (since nothing actually broke).
(Reporter)

Comment 3

8 years ago
Dave, am I correct when I say we do not have to run a backout? Can we start to mark all bugs with [fixed-in-addonsmgr] in the whiteboard entry as fixed now?
(Assignee)

Comment 4

8 years ago
(In reply to comment #3)
> Dave, am I correct when I say we do not have to run a backout? Can we start to
> mark all bugs with [fixed-in-addonsmgr] in the whiteboard entry as fixed now?

The current situation is that unless I have resolved the Ts regression by Saturday then I will have to backout everything. I could go either way on marking the bugs at this point, but obviously if I mark them all as fixed then I'll have to reopen them all if I backout.
(Reporter)

Comment 5

8 years ago
Ok, that makes sense.
(Assignee)

Comment 6

8 years ago
Created attachment 442874 [details] [diff] [review]
removed-files patch

In the event that we need to backout we need to also update removed-files. This should do it I believe based on comparing the windows zip files pre and post landing.
Attachment #442874 - Flags: review?(robert.bugzilla)
Attachment #442874 - Flags: review?(robert.bugzilla) → review+
(Assignee)

Comment 7

8 years ago
Backed out:

http://hg.mozilla.org/mozilla-central/rev/8a7a28c65fbd
http://hg.mozilla.org/mozilla-central/rev/1240ddeed985
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

8 years ago
Depends on: 563187
Depends on: 563012
(Assignee)

Comment 9

8 years ago
Created attachment 444574 [details] [diff] [review]
new removed-files.in patch (landed)

And need to update removed-files.in again now that we've relanded
Attachment #444574 - Flags: review?(robert.bugzilla)
Attachment #444574 - Flags: review?(robert.bugzilla) → review+
Comment on attachment 444574 [details] [diff] [review]
new removed-files.in patch (landed)

Pushed to mozilla-central
http://hg.mozilla.org/mozilla-central/rev/e5117ef37402
Attachment #444574 - Attachment description: new removed-files.in patch → new removed-files.in patch (landed)
(Assignee)

Updated

8 years ago
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a5
(Reporter)

Comment 11

8 years ago
Looks like it will be sticky now. Nothing major appeared after its landing. The Ts regression is known and not related to our code. Lets mark this bug as verified now.
Status: RESOLVED → VERIFIED
Flags: in-testsuite-
Flags: in-litmus-
Whiteboard: [rewrite]
You need to log in before you can comment on or make changes to this bug.