Last Comment Bug 561989 - The page is not auto scrolling, if you begin scrolling on table element with 'overflow:auto' and border style.
: The page is not auto scrolling, if you begin scrolling on table element with ...
Status: RESOLVED FIXED
: polish, testcase
Product: Core
Classification: Components
Component: XP Toolkit/Widgets: XUL (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Neil Deakin
Mentors:
Depends on: 755971
Blocks: 295977
  Show dependency treegraph
 
Reported: 2010-04-27 02:49 PDT by Alice0775 White
Modified: 2012-07-02 13:14 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (5.20 KB, text/html)
2010-04-27 02:49 PDT, Alice0775 White
no flags Details
testcase2 (614 bytes, text/html)
2010-04-27 04:38 PDT, Martijn Wargers [:mwargers] (not working for Mozilla)
no flags Details

Description Alice0775 White 2010-04-27 02:49:08 PDT
Created attachment 441745 [details]
testcase

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100426 Minefield/3.7a5pre ID:20100426040533
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100426 Minefield/3.7a5pre ID:20100426040533

The page is not auto scrolling if you begin scrolling on table element with
'overflow:auto' and  border width style.

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with New profile
2. Open testcase
3. Click middle mouse button on table element.

Actual Results:  
Auto scroll  marker shows NS-EW.
The page is not start scrolling.

Expected Results:  
The page (ancestor element) should scroll freely.
Comment 1 Martijn Wargers [:mwargers] (not working for Mozilla) 2010-04-27 04:38:30 PDT
Created attachment 441769 [details]
testcase2

Eventually, this seems like a bug in the scrollWidth/scrollHeight properties of the table element.
This returns in Firefox:
a.clientHeight: 25
a.offsetHeight: 65
a.scrollHeight: 65

But in IE8, it returns:
a.clientHeight: 25
a.offsetHeight: 65
a.scrollHeight: 25
Comment 2 Arpad Borsos [:Swatinem] 2010-04-27 04:45:18 PDT
So for normal block level elements,
offsetH/W is the outer dimensions of the element,
scrollH/W is the size of the content, as in a padding-box, so content+padding
clientH/W is the actually displayed size of the content (again, with padding).

for inline elements, such as spans, clientH/W suddenly becomes 0 ?!? (bug 561979)

and for the table element,
scrollH/W = offsetH/W, so it is the outer dimension of the table element.

Also, I've just looked up that CSS 2.1 [1] does only allow the overflow property on block-level (+ inline-block) and table-cell elements. This means that the usage seen in bug 561979 would be actually illegal.

[1] http://www.w3.org/TR/CSS21/visufx.html#propdef-overflow
Comment 3 Martijn Wargers [:mwargers] (not working for Mozilla) 2010-04-27 05:36:52 PDT
I filed bug 562005, for the issue mentioned in comment 1. If that bug would be fixed, this bug would be fixed automatically.
Comment 4 Alice0775 White 2012-07-02 13:14:21 PDT
I cannot reproduce anymore in
http://hg.mozilla.org/mozilla-central/rev/a31fc9052840
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120702030551

This was fixed by Bug 755971

Note You need to log in before you can comment on or make changes to this bug.