Scrollheight value of table with overflow:auto is too large, returns offsetHeight value

RESOLVED DUPLICATE of bug 755971

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 755971
8 years ago
6 years ago

People

(Reporter: Martijn Wargers (dead), Unassigned)

Tracking

({testcase})

Trunk
x86
Windows 7
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
This is a spin-off from bug 561989. That bug can probably be fixed, without having this bugs fixed.

See testcase,  there is a bug in the scrollWidth/scrollHeight properties of
the table element.
The testcase returns in Firefox:
a.clientHeight: 25
a.offsetHeight: 65
a.scrollHeight: 65

But in IE8, it returns:
a.clientHeight: 25
a.offsetHeight: 65
a.scrollHeight: 25

This might very well be related to bug 356665.
Blocks: 755971
This should be fixed with the patches from bug 755971, so marking as a dupe. Feel free to reopen if it isn't fixed.
No longer blocks: 755971
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 755971
You need to log in before you can comment on or make changes to this bug.