Closed Bug 562019 Opened 13 years ago Closed 13 years ago

Download instead of saving

Categories

(Firefox :: File Handling, defect)

3.6 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 120809

People

(Reporter: bumaga38, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100402 Remi/fc12 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100402 Remi/fc12 Firefox/3.6.3

When you click "Save as..." a picture it starts to be downloaded again though it has been fully downloaded and showing in the browser window.

Reproducible: Always

Steps to Reproduce:
1. Open an image URL (ex. http://interfacelift.com/wallpaper_beta/grab/02232_redrock_2560x1600.jpg)
2. Wait for it to fully download
3. Right-click it, choose "Save image as..." or Drag'n'Drop it from the browser window to the Desktop.
Actual Results:  
It starts to be downloaded AGAIN (oh my God).

Expected Results:  
Save the image file to the destination folder from cache, duh.

Even
1. opening a file manager
2. going to ~/.mozilla/firefox/whatever/Cache
3. sorting backwards by date modified
4. finding the picture by its preview
is faster than "Saving it as...".
Version: unspecified → 3.6 Branch
see also bug 143949
Severity: major → normal
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 120809
You need to log in before you can comment on or make changes to this bug.