Interface design problem: Users do not wish to be modally challenged on startup.

RESOLVED DUPLICATE of bug 551861

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 551861
8 years ago
8 years ago

People

(Reporter: Christian M. Cepel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)

Generally speaking, when a user launches a web browser, it's because they have a destination to reach.  They do not want to be challenged with an extra dialog they must dispatch before getting to the location dialog (or in my and other's case, the destination specified when launched from the Windows Run dialog).

I believe a user wants the ability to launch and then turn to other tasks and turn back to the browser when it has loaded and is ready to interact (i.e., it's loading existing sessions, a location dialog is available, etc).

Reproducible: Always

Comment 1

8 years ago
This is a known problem, see https://wiki.mozilla.org/Firefox/Projects/Eradicate_Startup_Dialogs

We don't appear to have a meta bug this one could be duplicated to. Do we need one, Alex?
(Reporter)

Updated

8 years ago
Summary: Interface design problem: Users do not with to be modally challenged on startup. → Interface design problem: Users do not wish to be modally challenged on startup.
we have a meta bug to cover all of notification, bug 551861.  It's still be set up with dependent bugs, but this is certainly an area that we are focusing on for the next release.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 551861
You need to log in before you can comment on or make changes to this bug.