[mac] problems sending / saving "Macintosh Files"

VERIFIED DUPLICATE of bug 22090

Status

MailNews Core
MIME
P3
normal
VERIFIED DUPLICATE of bug 22090
18 years ago
10 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: selmer (gone))

Tracking

Trunk
x86
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

I've got an attachment that is an apple script file that I can only send and
save using 4.x.  using 6.0 to send or save it will always fail.

when I send and then read and save from 4.x, it shows the attachment as a file
with type "Macintosh File", encoding 7 bit, description unknown

send from 4.x, read & read from 4.x:		ok
send from 4.x, read & read from 6.0:		fail (the file that I save to disk is just the
mime part, I'll attach it to the bug)
send from 6.0, read & save in 4.x:		fail (the file is empty)
send from 6.0, read & save in 6.0:		fail (the file is empty)

spamming a bunch of mac folks for input.
adding keywords 4xp.  is this a dogfood / rtm issue for mac users?
Keywords: 4xp
Created attachment 16900 [details]
this is what I get when I send from 4.x, and read and save from 6.0

Comment 3

18 years ago
I guess no one ever have time to deal with apple single/double mac specific file 
attachments.

Comment 4

18 years ago
Are we dropping part of multipart/appledouble?

This sounds bad for Mac users who want to send attachments, and should be rtm+ I 
think.
Keywords: nsmac1, rtm

Comment 5

18 years ago
Yes ...
I don't think so Apple Double is implemented yet. Rich?

Comment 7

18 years ago
Hoo boy. So we need to either refuse attachments that we know we'll fail to 
encode, or use BinHex. Do we do BinHex?

Comment 8

18 years ago
This was on my plate for a long time, but then I was told that the 4.x ongoing 
support team was going to help with Seamonkey issues so Steve Dagley told me he 
could help on the Mac. Here is the bug:

           http://bugzilla.mozilla.org/show_bug.cgi?id=22090

Comment 9

18 years ago
Should this be a dup of bug 22090?

Comment 10

18 years ago
Yes, this is a dup.
(Assignee)

Comment 11

18 years ago
Marking dup of 22090.


*** This bug has been marked as a duplicate of 22090 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 12

18 years ago
Verify as a duplicate of bug 22090.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.