Installing Jetpack extensions break UI buttons

VERIFIED DUPLICATE of bug 563562

Status

()

defect
P1
normal
VERIFIED DUPLICATE of bug 563562
9 years ago
9 years ago

People

(Reporter: tchung, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [AddonsRewriteTestday][rewrite])

Attachments

(1 attachment)

Reporter

Description

9 years ago
After installing a jetpack extension, the UI pane shows busted buttons.  See screenshot

Repro:
1) install nightly: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a5pre) Gecko/20100430 Minefield/3.7a5pre
2) install restartless jetpack extensions from here: https://secure.toolness.com/xpi/restartless/
3) visit addons manager and verify extensions pane has busted buttons.

Expected:
- buttons are working and visible for jetpack extensions like other extensions
Reporter

Updated

9 years ago
Blocks: 550048
Reporter

Comment 1

9 years ago
Actually, these highlighted entries in the screenshot shouldnt even appear right?  You shouldn have to "Restart Now". with these.  Ever.
Blair, I strongly believe we already have a bug filed on this, but I'm not able to find it. But Tony is right, we shouldn't show the 'Restart Now' section.
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: [AddonsRewriteTestday][rewrite] → [AddonsRewriteTestday][rewrite][DUPEME]
Priority: -- → P1
Blocks: 461973
No longer blocks: 550048
Whiteboard: [AddonsRewriteTestday][rewrite][DUPEME] → [AddonsRewriteTestday][rewrite]
(In reply to comment #2)
> But Tony is right, we shouldn't show the 'Restart Now' section.

Yea, that's just a consequence of other brokenness. Bug 563562 will fix this.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 563562
Reporter

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.