Add-ons Manager should list the currently available search engines even if they are not add-ons

VERIFIED DUPLICATE of bug 552747

Status

()

defect
VERIFIED DUPLICATE of bug 552747
9 years ago
4 years ago

People

(Reporter: mozilla.bugs, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [AddonsRewriteTestday][rewrite])

This may be impossible to change, but in the new add-ons manager, the "Search Engines" option is limited to search engine add-ons.  For thoroughness--whether the user can interact with these list items or not--it should list the search engines that are available, rather than simply say "You don't have any add-ons of this type."

When I clicked on it, I expected to see the list of search engines that I had.
Works just fine for me. I always see the installed search engines on my machine. Can you also reproduce it with a fresh profile?
Blocks: 550048, 558289
Severity: enhancement → normal
Whiteboard: [AddonsRewriteTestday] → [AddonsRewriteTestday][rewrite]
Version: unspecified → Trunk
This is something that didn't quite get completed for the trunk landing and so
is only on the project branch right now
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 552747
No longer blocks: 550048, 558289
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.