Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 56311 - Netscape 6 doesn't call NPP_UrlNotify() when a stream requested with NPN_GetUrlNotify() completes
: Netscape 6 doesn't call NPP_UrlNotify() when a stream requested with NPN_GetU...
Status: VERIFIED DUPLICATE of bug 117766
[need testcase to verify fix]
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: All All
: P2 normal (vote)
: mozilla1.1alpha
Assigned To: av (gone)
: shrirang khanzode
: Benjamin Smedberg [:bsmedberg]
: 112399 (view as bug list)
Depends on:
Blocks: 55959 104166 112399
  Show dependency treegraph
Reported: 2000-10-12 14:38 PDT by kcunningham
Modified: 2008-07-31 10:14 PDT (History)
7 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description kcunningham 2000-10-12 14:38:40 PDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; N; PPC; en-US; m18) Gecko/20000929
BuildID:    2000092911

 Netscape 6 doesn't call NPP_UrlNotify() when a stream requested with
NPN_GetUrlNotify() completes

Reproducible: Always
Steps to Reproduce:
  his is a Netscape 6 bug.

When a plugin requests a stream using NPN_GetUrlNotify(), the browser is
supposed to invoked NPP_UrlNotify() when the stream is complete. There are two
primary cases, the browser sent NPP_NewStream() to the plugin, in which case
NPP_DestroyStream() will happen and we don't really care (as we do redundant
work in NPP_DestroyStream and NPP_UrlNotify). But if there was a problem with
the stream, so NPP_NewStream() is not sent, NPP_UrlNotify() is the only way know
to stop waiting for the stream.

Actual Results:

Expected Results:
Comment 1 ekrock's old account (dead) 2000-10-18 13:29:22 PDT
Kelly, Meridith -- To help us triage:
1) what is the user experience when this problem happens?
2) does it ever cause a crash?
3) is there Shockwave functionality that doesn't work as a result? if so, what?
4) among Shockwave content, how widespread is content that will trigger this 
5) is there a workaround?
6) could MM provide an engineering resource to implement a fix?
Thanks for the report, and please let us know ASAP. Thanks!
Comment 2 ekrock's old account (dead) 2000-10-18 16:35:58 PDT
Confirming and marking Future and [rtm-] based on comments received by email 
from Macromedia. (Will paste those in here when I verify that the info isn't MM 
confidential.) This doesn't hurt Shockwave hardly at all although it could 
impact plug-ins based on the NS 3.0 Plug-in API. If we get evidence of 
unacceptable impact on other high-priority plug-ins in time for RTM, we'll 
Comment 3 James Paige 2000-11-14 14:34:01 PST
Plugin API issues are a bit over my head, but this sounds very much like its
related to a problem I have had. I have a shockwave game that works just fine in
Nestscape 4.x IE 4.x, 5.x and even Opera 3.x, but in Mozilla, it gets stuck
right after the loading sequence. (Id give you the URL, but the game is kinda
proprietary, so until I get permission, or have enough spare time to write a
test case, a description will have to do.)

This shockwave game loads its first frame, and then waits until the entire .DCR
file has ben downloaded before proceeding. Its progress meter shows the download
is working, but when it reaches 100 percent, it stops, and the "Loading" caption
fails to turn into a "Its ready!" button. If Mozilla is failing to notify the
plugin that the stream has finished, I can easyly see something like this
happening. If I can come up with a good example file, Ill post it for ya.
Comment 4 ekrock's old account (dead) 2001-01-18 12:36:03 PST
Nominating nsbeta1 based on (1) the higher degree of backward compatibility with
plug-ins we're trying to achieve for nsbeta1 than we had for RTM, and (2) above
user report of a possible example of where this is actually causing trouble.
However, Andrei, if you run out of time, this is a lower priority than the other
plug-in bugs for which we have confirmed examples of user impact. Fix this one
last unless when get positive confirmation of cases where this causes harm.
Comment 5 Peter Lubczynski 2001-01-26 10:40:55 PST
I think I may be able to fix this, but I need a testcase.

MozillaUser, can you attach a testcase?
Comment 6 James Paige 2001-01-26 14:51:25 PST
hmm, perhaps not. I just re-tested (with build 2001012404) the proprietary game
that I had the problem with earlier, and it no longer has any problems. So
either I was mistaken in my guess that my problem was caused by this bug, or
someone else has fixed this as as part of some other bug :P

Sorry I cant be more helpful. I suppose you will have to ask
Comment 7 shrirang khanzode 2001-01-28 21:27:53 PST
I cannot test this without a testcase..any ideas anyone if this is 
still happening or is it fixed? Thx!
Comment 8 Peter Lubczynski 2001-02-12 10:32:42 PST
Increasing priority as there are many newsgroup posts about this bug.
Comment 9 Peter Lubczynski 2001-03-27 13:07:24 PST
Sounds up my alley
Comment 10 Eric Krock 2001-04-08 14:47:53 PDT
Peter, are we shooting for a milestone sooner than Future? (current value) 
Adding nomination to mozilla0.9.1. Can any of the newsgroup posters supply a 
Comment 11 Peter Lubczynski 2001-04-08 22:16:53 PDT

Are you back?

I quickly looked at the code and it looks fine. We could possibly up to 0.9.1 if 
there was a solid testcase attached to verify I actually fixed the problem.

Comment 12 Eric Krock 2001-04-09 10:12:16 PDT
I'm back from my sabbatical in Europe, have been with Zodiac Networks since 
2/14, not back at Netscape in the sense of being on the payroll, but still 
involved with & interested in polishing off the technologies I used 
to manage.
Comment 13 Peter Grandmaison 2001-04-09 13:50:18 PDT
Erik, macromedia doesn't have a test case for this. I noticed this last fall 
when stepping in the debugger, and although it doesn't matter to shockwave, I 
felt it was a pretty serious compatibility bug, so I filed it (through Kelly).
Comment 14 Eric Krock 2001-04-09 14:11:29 PDT
Thanks Peter. Could you give us more background on why you felt this was a 
potentially serious issue? (e.g. Do you know of other plug-ins that would be 
affected, or can you suggest where we might get a testcase?) Thanks for your 
Comment 15 Meredith Tomlin 2001-04-11 10:34:39 PDT
As for this bug, we decided a while ago that this isn't a must fix for us.  
Reason being, for a properly set up website, this functionality is never used. 
It is part of our error handling for bad urls, and without it will cause 
shockwave to wait indefinately for streams to connect instead of terminating 
them when the browser notifies us that a stream is not coming.  Thus, this bug 
can be closed.
Comment 16 James Paige 2001-04-11 12:42:28 PDT
ooh! Meredith's comments are very helpful. I have something now that I *think*
is a test case that proves this bug has already been fixed. is a sample shockwave
pre-loader. When you run it, it is going to ask for permission to access . grant it permission

While the hamster runs, the loader will load two game files, and then a 1
megabyte ZIP file (just to make the progress meter take long enough for you to
see) and finally it will request the nonexistant file

After all the files have been downloaded, the "Loading.." text is replaced by
"Its ready! Click Here!". If Mozilla was failing to notify the plugin that the
file request had failed, then that button would appear-- but it does!

If the original .DIR source file for this example would helpful in verifying or
debunking the validity of my testcase, I would be happy to mail it to someone,
but I prefer not to post it
Comment 17 Eric Krock 2001-04-11 14:14:46 PDT
MozillaUser: Am I correct in thinking that you meant to write: "If Mozilla was 
failing to notify the plugin that the file request had failed, then that button 
would *NOT* appear-- but it does!" (*NOT* added) Many thanks for your testing!
Comment 18 James Paige 2001-04-11 14:27:35 PDT
Ah, yes. absolutely. I was _thinking_ "would not appear" but I _wrote_ "would

just filed bug 99999999 "Buzilla is unable to read my mind" with blocker
severity to track that issue.

Comment 19 Tristan Nitot 2001-11-26 11:50:02 PST
This bug seems a major problem for Business Objects in order to support Netscape
6.2+ and Mozilla with their software package. Adding me in CC field.
Comment 20 Peter Lubczynski 2001-11-26 13:25:39 PST
Tristan, do you have a testcase setup to show the problem? Thanks!
Comment 21 Tristan Nitot 2001-11-27 02:40:16 PST
PeterL : I have asked Business Objects to provide one. We should also set up a
concall soon to discuss the issue, with you or Patrick Beard.
Comment 22 Peter Lubczynski 2001-11-28 15:22:28 PST
I have a few dups of this bug but looking at the source, it's hard to determine
the code path that would NOT cause a NPP_UrlNotify(). This is why I really need
a testcase. Nominating for mozilla1.0
Comment 23 Tristan Nitot 2001-11-29 08:02:04 PST
The test case should be provided in this bug or in bug  112399 . 
Adding CC

Jacques : could you please provide us with a test case you can upload in here
(see "create a new attachment" link).
Comment 24 Peter Lubczynski 2002-02-05 17:59:40 PST
--->over to Andrei, do you remember what were the conditions to trigger this bug?
Comment 25 Denis Antrushin 2002-02-28 10:26:06 PST
Is is about ns4xPluginInstance.cpp line 223?
We call NPP_NewStream here and if some error happens, just 
returning with error from ns4xPluginStreamListener::OnStartBinding().
Should we call NPP_UrlNotify() here (line 233 - 234)?
(Well, I'm just speculating here, due to lack of testcase)
Comment 26 R.K.Aa. 2002-03-11 16:48:52 PST
will this be fixed by the patch in bug 127259?
Comment 27 Peter Lubczynski 2002-03-11 17:17:19 PST
Maybe fixed...

Does anyone at Macromedia have a testcase to verify this bug gets fixed?
Comment 28 Tristan Nitot 2002-04-30 19:43:37 PDT
Jacques : could you please download Mozilla 1.0RC1 and check on you
configuration if the bug is fixed ?
Comment 29 Peter Lubczynski 2002-04-30 20:44:46 PDT
Note: This has probably only been fixed for NULL targets. There is another bug
about fixing this for non-NULL targets.
Comment 30 rubydoo123 2002-05-30 14:27:02 PDT
moving back to 1.0.1
Comment 31 rubydoo123 2002-05-30 14:27:50 PDT
drats, meant 1.1
Comment 32 rubydoo123 2002-07-09 12:50:00 PDT
*** Bug 112399 has been marked as a duplicate of this bug. ***
Comment 33 rubydoo123 2002-07-09 12:57:47 PDT
*** This bug has been marked as a duplicate of 117766 ***

*** This bug has been marked as a duplicate of 117766 ***
Comment 34 shrirang khanzode 2002-07-18 15:14:59 PDT

Note You need to log in before you can comment on or make changes to this bug.