Excessive Line Wrapping at 1024x768

VERIFIED FIXED in 5.11.1

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
8 years ago
2 years ago

People

(Reporter: chowse, Assigned: chowse)

Tracking

unspecified
5.11.1

Details

(URL)

Attachments

(3 attachments)

(Assignee)

Description

8 years ago
Created attachment 443149 [details]
Examples

When browsing at 1024x768, several highly visible components on AMO are too wide to fit on a single line, and are wrapping in very sloppy ways (see attached screenshot).

Users browsing at 1024x768 still represent a significant portion of the population (see http://browsersize.googlelabs.com/), and with the rise of netbooks, this number is not diminishing.

Several of the most visible problem are also trivial fixes:

* In the promo, reduce the space between labels (i.e. Introduction, Shopping, Sports, ...).

* In the add-on directories, reduce space between the filtering/sorting options (i.e. Featured, Popular, ...).

* For add-on entries, remove the word 'reviews', use a more compact date format (e.g. YYYY/MM/DD), use an icon rather than 'weekly downloads', and remove the left margin around the description and metadata. (okay, maybe this wasn't trivial)

Comment 1

8 years ago
Created attachment 445387 [details]
A piece of Russian text in "What are Add-ons?" doesn't fit.

A piece of Russian text in "What are Add-ons?" doesn't fit. It doesn't seem to be possible to shorten it enough to fit without loss of the sense and style.

Updated

8 years ago
Whiteboard: [amotestday]
(Assignee)

Comment 2

8 years ago
In the examples I cited above, the wrapping occurred not because a string was too long, but because there was excessive whitespace between several page elements. Eliminating these would be a trivial change, have no adverse effect on style or usability, and would make the page look more polished. This clearly won't address the problem for all locales, but it is an easy win for quite a few of them.
We're using [amotestday] to denote bugs which come from the testday (not just ones we've re-confirmed).
Whiteboard: [amotestday]
(Assignee)

Comment 4

8 years ago
CSS fixes for most of the problems mentioned above:
http://github.com/chowse/zamboni/commit/cef132122698f8ee41003273075505d7de11225b

Updated

8 years ago
Assignee: nobody → chowse
Target Milestone: --- → 5.11.1
Is this bug done?  If so, can we close it?
(Assignee)

Comment 6

8 years ago
Needs a pull into master. Jeff?
Assignee: chowse → jbalogh
http://github.com/jbalogh/zamboni/commits/a03f7dbfd
Assignee: jbalogh → chowse
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 8

8 years ago
(In reply to comment #1)
> Created an attachment (id=445387) [details]
> A piece of Russian text in "What are Add-ons?" doesn't fit.

Filed as bug 570673.
We didn't do the last suggestion mentioned in comment 0; are we OK with that?  The rest looks good...
(Assignee)

Comment 10

8 years ago
I'm fine w/ punting on that. It's a much more complex change, and the line wrapping in the entry block looks less orphaned than the other cases.
Created attachment 449924 [details]
Post-fix screenshot (1024x768)w
Verified FIXED running 1024x768 on preview.AMO
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.