Use system colors in CSS wherever possible, instead of hardcoded colors

RESOLVED WONTFIX

Status

()

defect
RESOLVED WONTFIX
9 years ago
9 years ago

People

(Reporter: Unfocused, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rewrite])

Most colors are currently hardcoded. They should be changed to be system colors wherever possible. BUT this should be done *after* we have a finalized visual style, so we're not wasting time changing things that will just be changed again.
Version: unspecified → Trunk
Blocks: 562935
Blocks: 562865
blocking2.0: --- → final+
Changes here doesn't affect any theme developer, right?
It would affect them a little if they are copying our theme code as a basis, not sure if that makes it worthy of being a beta blocker or not. Since it seems the theme won;'t be finalised by beta, probably not.
Blocks: 572090
No longer blocks: 572090
Duplicate of this bug: 577238
Assignee: nobody → bmcbride
What is the magnitude of work here, and does it still block as the EM UI has changed a fair bit since May?
Yea, its still an issue. Its part of my ongoing work on bug 601022 - which is a lot of inter-dependent theme-related work, so I'm fixing a lot of dependent bugs (like this) at once.
Depends on: 601022
Status: NEW → ASSIGNED
Per the meeting and UX guidance we've decided that (apart from Linux where we will be using native styles for the most part) the add-ons manager appears in the content area and so need not necessarily fit in with the OS conventions as much as the rest of the UI, so this bug it really a wontfix now.
Assignee: bmcbride → nobody
Status: ASSIGNED → RESOLVED
blocking2.0: final+ → ---
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
No longer blocks: 562865
Is this something that we woudln't fix if we had solid patches in hand? I understand it not being a priority, but it seems like something that would be useful even if it doesn't make it into Firefox 4.
(In reply to comment #7)
> Is this something that we woudln't fix if we had solid patches in hand? I
> understand it not being a priority, but it seems like something that would be
> useful even if it doesn't make it into Firefox 4.

The problem is that the system colours available to us in CSS don't really match with the UI stylings that we want to do, it's more of a "cantfix without degrading the UI" than a wontfix
OK. Thanks for the follow-up. That makes sense to me and the resolution seems good considering that.
Has anyone checked how the chosen colors interact with changes to modified theme colors. One thing I have seen happen with Firefox and other Mozilla applications is that custom colors are chosen that work well / ok with the default theme colors but if the default colors are changed the custom colors fail badly.
You need to log in before you can comment on or make changes to this bug.