ProfileManager deletes more than just the profiles.

VERIFIED DUPLICATE of bug 302087

Status

defect
VERIFIED DUPLICATE of bug 302087
9 years ago
9 years ago

People

(Reporter: ryan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.1.249.1064 Safari/532.5
Build Identifier: 3.0.4

Thunderbird's profile manager will proceed to delete every mail profile you have because for some reason it seems to do a blind recursion into the sub-folders of the profile you wanted deleted instead of actually checking the profile itself for what it should, and more importantly shouldn't delete.

Reproducible: Always

Steps to Reproduce:
1. Open ProfileManager and create a new profile.
2. Select the default profile location but fail to choose a subfolder.
3. Ooops, change your mind and decide to delete that profile.
4. Check the box to delete the few dozen files you just created.
Actual Results:  
It will apparently delete anything there with amazing speed. EVERYTHING. I actually shut my computer when I realized my mail folders were getting wrecked, like 10 seconds max, but by then it had wiped 2GB of mail, and even undelete could not restore them!

Expected Results:  
profile manager to delete the files that were part of that select profile, not recurse into obviously unrelated sub-folders. 

The whole point was I had made the profile in a dumb place and wanted it to clean up the files it put there, not EVERY SUB-FOLDER! God forbid someone accidentally point it at their system folders and check that file destroying check box! It'll take the whole thing out. 3 months of email is swimming with the fishes because someone thinks blind recursive deletion is acceptable behavior for a data management product. It's not, and as a developer I know someone will say that warning message makes it clear, but I read the warning message and it says the profile that's at that location, not that profile and every other one it can get to before you can shut off the computer. In the Windows version it really wouldn't hurt to pass deletes off to the OS so they go to the recycle bin, but that's just a wish.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 302807
Reporter

Comment 2

9 years ago
wow, that's really a stretch. Very little resemblance to that other issue at all.
Status: RESOLVED → VERIFIED
This is essentially a special case of Bug 302087 where the other folder happens to be the directory of the profiles.  There's another bug on the profile deletes should go to the recycle bin issue but I can't find it ATM.
Reporter

Comment 5

9 years ago
oh, yes, I agree with that. I must have only searched for profile manager one word. My mistake.
You need to log in before you can comment on or make changes to this bug.