If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

JavaScript component does not have a method named: "observe" when calling method: [nsIObserver::observe] (NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED)

RESOLVED WORKSFORME

Status

Fennec Graveyard
General
RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: Martijn Wargers (dead), Assigned: mfinkle)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
I'm seeing this error in the js console when clicking on the "Clear Private Data" button in the options:
[Exception... "'JavaScript component does not have a method named: "observe"' when calling method: [nsIObserver::observe]"  nsresult: "0x80570030 (NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED)"  location: "JS frame :: chrome://browser/content/sanitize.js :: anonymous :: line 171"  data: no]

It seems to be happening when you have an about: url (about:firefox, etc) opened.

(to be able to see js errors, make sure you have the javascript.options.showInConsole pref set to true and the browser.console.showInPanel set to true in about:config)

I'm seeing this on trunk and branch as on windows and Maemo.
(Assignee)

Updated

7 years ago
Whiteboard: mobile-triage
(Assignee)

Updated

7 years ago
Assignee: nobody → mark.finkle
(Assignee)

Updated

7 years ago
Whiteboard: mobile-triage
Duplicate of this bug: 614134
Mozilla/5.0 (Android; Linux armv71; rv2.0b8pre) Gecko/20101122 Firefox/4.0b8pre Fennec/4.0b3pre
Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b8pre) Gecko/20101122 Firefox/4.0b8pre Fennec/4.0b3pre

1. go to http://www.bestbuymobile.com
2. go to http://www.rottentomatoes.com
3. go to http://www.cnn.com
4. go to http://www.espn.com
5. go to http://www.bbc.co.uk/news/
6. go to the control side panel
7. go to the preferences
8. hit the clear button to clear private data
9. go to the error console

Expected: No errors
Actual: 
Error: [Exception... "'JavaScript component does not have a method named: "observe"' when calling method: [nsIObserver::observe]" nsresult: "0x80570030 (NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED)" location: "JS frame :: chrome://browser/content/sanitize.js :: <TOP_LEVEL> :: line 195" data: no]  Source File: chrome://browser/content/sanitize.js Line: 195
OS: Windows 7 → All
Hardware: x86 → All
Created attachment 536876 [details]
screenshot

It is still reproducing on:
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:7.0a1)Gecko/201100602
Firefox/7.0a1 Fennec/7.0a1
Device: LG Optimus 2x
OS: Android 2.2
Seeing this on today's nightly on start-up clean profile

Mozilla/5.0 (Android; Linux armv7l; rv:8.0a1) Gecko/20110721 Firefox/8.0a1 Fennec/8.0a1 
Device: Samsung Nexus S
OS: Android 2.3.4
(Assignee)

Updated

6 years ago
Duplicate of this bug: 675204
(Reporter)

Comment 6

5 years ago
Mass resolving XUL Fennec I filed to WORKSFORME. If someone still cares about this bug, please reopen.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.