Updating an add-on that is incompatible to a version that is compatible requires more restarts

VERIFIED FIXED in mozilla1.9.3a5

Status

()

Toolkit
Add-ons Manager
P1
normal
VERIFIED FIXED
8 years ago
4 years ago

People

(Reporter: mossop, Assigned: mossop)

Tracking

Trunk
mozilla1.9.3a5
Points:
---
Bug Flags:
in-testsuite +
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rewrite])

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
After the automatic update of adblock plus to version 1.2 the user restarts, during the startup no EM restart occurs:

*** LOG addons.xpi: startup
*** LOG addons.xpi: Skipping unavailable install location app-system-share
*** LOG addons.xpi: Ignoring file entry whose name is not a valid add-on ID: /Users/dave/Library/Application Support/Mozilla/Extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/.DS_Store
*** LOG addons.xpi: Ignoring file entry whose name is not a valid add-on ID: /Users/dave/Library/Application Support/Firefox/Profiles/Test/extensions/.DS_Store
*** LOG addons.xpi: checkForChanges
*** LOG addons.xpi: Processing install of {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} in app-profile
*** LOG addons.xpi: Found updated manifest for {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} in app-profile
*** WARN addons.xpi: Ignoring file: /Users/dave/Library/Application Support/Firefox/Profiles/Test/extensions/staged/{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}.json
*** LOG addons.xpi: Add-on {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} modified in app-profile
*** LOG addons.xpi: No changes found
*** LOG addons.xpi: shutdown

This leaves no chrome or components loaded for the extension.
(Assignee)

Updated

8 years ago
Summary: Updating adblock plus doesn't force an EM restart → Updating an add-on that is incompatible to a version that is compatible requires more restarts
(Assignee)

Comment 1

8 years ago
Created attachment 443735 [details] [diff] [review]
patch rev 1

The problem is that the new value of the active property for the add-on is only put into the database, but code tries to read it from the addon instance and decides whether an EM restart is necessary based on it.
Attachment #443735 - Flags: review?(robert.bugzilla)
(Assignee)

Comment 2

8 years ago
http://hg.mozilla.org/projects/addonsmgr/rev/d0fe313e6030
Flags: in-testsuite+
Whiteboard: [rewrite] → [rewrite][fixed-in-addonsmgr][needs-review]
Attachment #443735 - Flags: review?(robert.bugzilla) → review+
Whiteboard: [rewrite][fixed-in-addonsmgr][needs-review] → [rewrite][fixed-in-addonsmgr][needs-landing]
(Assignee)

Comment 3

8 years ago
http://hg.mozilla.org/mozilla-central/rev/40af35f84231
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Whiteboard: [rewrite][fixed-in-addonsmgr][needs-landing] → [rewrite]
Target Milestone: --- → mozilla1.9.3a5
Verified fixed by checkin and a passing automated test.

Dave, anything we can/have to test manually?
Status: RESOLVED → VERIFIED
Flags: in-litmus?
(Assignee)

Comment 5

8 years ago
No I think the automated test is fine here
Flags: in-litmus? → in-litmus-
You need to log in before you can comment on or make changes to this bug.