Form data deletes don't sync

RESOLVED DUPLICATE of bug 735532

Status

Cloud Services
Firefox Sync: Backend
RESOLVED DUPLICATE of bug 735532
8 years ago
6 years ago

People

(Reporter: tracy, Unassigned)

Tracking

unspecified
Future
Points:
---
Bug Flags:
blocking-weave1.3 -
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed by bug 487558)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Seen with 1.3b4

1) In a form or search field, enter a few terms to populate the form data list
2) Sync the data from client A to client B
3) On Client A, remove a data item from the form/search field by highlighting it and hitting ctrl+shift+delete
4) Sync that form change to client B

Tested results:
The deleted item on A remains on client B

Expected results:
The data item should be also sync/deleted on client B

Same result if you Clear All Form and Search History

Both clients form history remains out of sync regarding deletes.
Flags: blocking-weave1.3?
This is known, and really a dupe of syncing everything based on notifications that satchel doesn't provide, yet.  Since we don't have a notification to observe for deletes, we can't yet sync them.
Flags: blocking-weave1.3? → blocking-weave1.3-
(Reporter)

Comment 2

8 years ago
ok, making this depend on the satchel bug 487558
Depends on: 487558

Updated

8 years ago
Target Milestone: --- → Future

Comment 3

7 years ago
This should be fixed ?
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Whiteboard: fixed by bug 487558

Updated

7 years ago
Flags: in-testsuite?
(Reporter)

Updated

7 years ago
Duplicate of this bug: 568363

Comment 5

7 years ago
Created attachment 475597 [details]
Crossweave test case

Comment 6

7 years ago
Created attachment 475598 [details]
crossweave test log

Comment 7

7 years ago
Crossweave automation test fails.Check the crossweave test log.

Reopening the bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 8

7 years ago
This is currently not fixed.  It may have regressed since.

Sorry it took so long. I really need to get caught up on verifications.  :-/

Updated

7 years ago
Attachment #475597 - Attachment mime type: application/octet-stream → text/plain

Updated

7 years ago
Attachment #475598 - Attachment mime type: application/octet-stream → text/plain
This is only fixed on trunk.  Crossweave runs using 3.6.x will fail this test, but that's not something we're going to fix.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Flags: in-testsuite? → in-testsuite+

Updated

7 years ago
Flags: in-testsuite+ → in-testsuite?
(Reporter)

Comment 10

7 years ago
On trunk builds from 20101013 with a new account, this is still not working.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
tracy, is this still a problem?
(Reporter)

Comment 12

6 years ago
yes, still present as confirmed on m-c from 20120308
(Reporter)

Comment 13

6 years ago
duping to recent bug as it is getting traction.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 735532
You need to log in before you can comment on or make changes to this bug.