Closed Bug 487558 Opened 13 years ago Closed 12 years ago

Use satchel notifications to track form data

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Future

People

(Reporter: Mardak, Assigned: philikon)

References

Details

Attachments

(1 file)

The fix in bug 487541 reimplements the logic that satchel uses to decide if an input should be saved. Bug 487556 will provide the satchel notifications, so when that's fixed, we should use them in weave.
Target Milestone: -- → 1.0
Component: Weave → General
Product: Mozilla Labs → Weave
Version: Trunk → unspecified
QA Contact: weave → general
Component: General → Sync
QA Contact: general → sync
Target Milestone: 1.0 → ---
Depends on: 506402
Target Milestone: --- → Future
Blocks: 559700
Blocks: 564296
Duplicate of this bug: 584123
We should
* nuke its Gecko 2.0 XPCOM registrations
* move it to the 'addon' directory
* make engines/form.js aware of the new-style notifications (while keeping
support for the old-style notifications as long as we support 3.5/3.6)
(In reply to comment #2)
> We should
> * nuke its Gecko 2.0 XPCOM registrations
> * move it to the 'addon' directory
> * make engines/form.js aware of the new-style notifications (while keeping
> support for the old-style notifications as long as we support 3.5/3.6)

it = FormNotifier.js
Attached patch v1Splinter Review
Made the form tracker listen to the 'satchel-storage-changed' notification which is sent by Firefox 4. That makes FormNotifier.js unnecessary on that platform, so moved it to the 'addon' directory and removed it from the manifest. The former means it will no longer be exported to mozilla-central. The latter means it will be disabled when the add-on is installed on Firefox 4.

(Note that the patch is against the patches from bug 584241.)
Assignee: nobody → philipp
Attachment #463209 - Flags: review?(mconnor)
Attachment #463209 - Flags: review?(mconnor) → review+
http://hg.mozilla.org/services/fx-sync/rev/553ec48a5c4c
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Depends on: 587541
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.