Closed Bug 564337 Opened 11 years ago Closed 7 years ago

Make window.showModalDialog tab-modal

Categories

(Core :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: Dolske, Unassigned)

References

(Blocks 2 open bugs, )

Details

Bug 562258 adds support for making a number of dialogs tab-modal. I've punted on support for a tab-modal flavor of showModalDialog(), because it looks a bit more complex and since it's a different code path it can have a tab-modal done separately.
(The likely implementation for this would be a <iframe> over the tab's content)
Duplicate of this bug: 616839
Blocks: 59314
Blocks: eviltraps
Could someone please mark this as blocking bug 616843, in which I'm trying to
list all dialogs that should be tab-modal?
Blocks: 616843
Depends on: 574797
See Also: → 627151
No longer depends on: 574797
Whiteboard: [feature] p=0
No longer blocks: fxdesktopbacklog
Flags: firefox-backlog+
Whiteboard: [feature] p=0 → p=0
Given bug 981796 (remove showModalDialog) is this a wontfix?
Flags: needinfo?(dolske)
Oh, that's fantastic. Wish we had done that back in bug 627151, though.

But yeah, even if we keep it I don't think we want to bother making it tab-modal.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(dolske)
Resolution: --- → WONTFIX
Flags: firefox-backlog+
Whiteboard: p=0
You need to log in before you can comment on or make changes to this bug.