crash when I'm going to view Ogg Theora format video on full screen mode [@ InternalFindAtom]

RESOLVED WORKSFORME

Status

()

Core
Audio/Video
--
critical
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: memai, Assigned: jrmuizel)

Tracking

({crash, regression, relnote})

Trunk
x86
Windows XP
crash, regression, relnote
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Whiteboard: [needs jrmuizel's input], crash signature, URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100506 Minefield/3.7a5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100506 Minefield/3.7a5pre

Firefox crashed When I'm going to view Ogg Theora video(online and local file) on full screen mode.


Reproducible: Always

Steps to Reproduce:
1.load http://www.mozilla.com/en-US/firefox/video/
2.click play button on "Meet Firefox" video
3.right click on the video->context menu->select Full Screen
Actual Results:  
Firefox crashed

Expected Results:  
play the video on full screen mode

video card:Matrox Millennium G450 DualHead

OK
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100426 Minefield/3.7a5pre
bad
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100427 Minefield/3.7a5pre

Crash ID
Build ID:20100506040636
http://crash-stats.mozilla.com/report/index/bp-e3916602-5ada-48e9-a345-5171c2100507
http://crash-stats.mozilla.com/report/index/bp-4a7c5e8f-af20-41a8-9538-153152100507
http://crash-stats.mozilla.com/report/index/bp-1dcf8cba-aa82-408b-9982-f665d2100507

Build ID:20100502040440
http://crash-stats.mozilla.com/report/index/bp-3c651994-1d20-471f-a787-54ab42100502
(Reporter)

Updated

7 years ago
Version: unspecified → Trunk

Comment 1

7 years ago
I'm assuming this is some sort of OOM. the frames past nsIntRegion are kinda strange, so i'm trying to ignore them.

Signature	@0x0 | InternalFindAtom
UUID	1dcf8cba-aa82-408b-9982-f665d2100507
Time 	2010-05-07 01:52:15.585202
Uptime	26
Last Crash	45 seconds before submission
Product	Firefox
Version	3.7a5pre
Build ID	20100506040636
Branch	1.9.3
OS	Windows NT
OS Version	5.1.2600 Service Pack 3
CPU	x86
CPU Info	GenuineIntel family 15 model 2 stepping 4
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x0
User Comments	view ogg theora video/select full screen
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 		@0x0 	
1 	kernel32.dll 	InternalFindAtom 	
2 	user32.dll 	_GetWindowLong 	
3 	user32.dll 	PtiWindow 	
4 	user32.dll 	_FindProp 	
5 	mozcrt19.dll 	arena_malloc_small 	obj-firefox/memory/jemalloc/crtsrc/jemalloc.c:3734
6 	xul.dll 	nsIntRegion::nsIntRegion 	obj-firefox/dist/include/nsRegion.h:293
7 	xul.dll 	nsBaseWidget::GetLayerManager 	
8 	xul.dll 	GetLayerManagerForDoc 	content/html/content/src/nsHTMLMediaElement.cpp:1823
9 	xul.dll 	nsHTMLMediaElement::GetImageContainer 	content/html/content/src/nsHTMLMediaElement.cpp:1849
10 	xul.dll 	nsBuiltinDecoder::Init 	content/media/nsBuiltinDecoder.cpp:121
11 	xul.dll 	nsHTMLMediaElement::InitializeDecoderAsClone 	content/html/content/src/nsHTMLMediaElement.cpp:1423
12 	xul.dll 	nsHTMLMediaElement::MozLoadFrom 	content/html/content/src/nsHTMLMediaElement.cpp:783
13 	xul.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:102
14 	xul.dll 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1770
15 	mozjs.dll 	js_Invoke 	js/src/jsinterp.cpp:823
16 	mozjs.dll 	js_Interpret 	js/src/jsops.cpp:2226
17 	mozjs.dll 	js_Invoke 	js/src/jsinterp.cpp:831
18 	xul.dll 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1696
19 	xul.dll 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:570
20 	xul.dll 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:114
21 	xul.dll 	SharedStub 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:141
22 	xul.dll 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:1085
Severity: normal → critical
Component: Video/Audio → jemalloc
Keywords: crash
QA Contact: video.audio → jemalloc
Summary: crash when I'm going to view Ogg Theora format video on full screen mode → crash when I'm going to view Ogg Theora format video on full screen mode [@ InternalFindAtom]

Comment 2

7 years ago
Build Worked: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a5pre) Gecko/20100426 Minefield/3.7a5pre
http://hg.mozilla.org/mozilla-central/rev/2968d19b0165
Build Broken: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a5pre) Gecko/20100427 Minefield/3.7a5pre
http://hg.mozilla.org/mozilla-central/rev/29a6a85fab8e

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2968d19b0165&tochange=29a6a85fab8e

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

7 years ago
Duplicate of this bug: 565864
I can crash consistently using a hardware machine, but not on my XP vm. Crash signatures can vary, though.
blocking2.0: --- → ?
Keywords: regression
Here are the crash reports for this issue on my machine:

bp-fe7b2cb5-6864-4247-9204-4cb362100514
bp-82a2e819-04f6-437e-8392-2a2b52100514
bp-501e4327-df0c-452b-b93f-e742a2100514
blocking2.0: ? → beta1+
Component: jemalloc → Video/Audio
QA Contact: jemalloc → video.audio

Updated

7 years ago
Duplicate of this bug: 566555

Comment 7

7 years ago
Crash reports for my Atom Netbook with Intel GMA 950 on XP:
(1. while using fresh Profile)
bp-ccbbe5ec-7336-4f55-94f2-9e9dc2100617
bp-69e02b7d-4a58-40d8-8430-9ba112100617
bp-2a3dfa36-3bc4-444f-afb3-968f52100617

BTW, same crashes happen for webm Videos.

Comment 8

7 years ago
This seems to be related to Layers (and new DX9 Backend)
When setting mozilla.widget.accelerated-layers to false, no crashes...

Latest official XP Driver for GMA 950 (igxprd32 6.14.10.4926) supports OpenGL 1.4 (so no Fullscreen accel. before DX9 Backend) and DirectX 9.0/ SM2.0
Roc, leaving this as a beta1 blocker, but please bump it if you think appropriate.
Can we get an owner for this asap?
Jeff, suspect D3D9 layers here. Can you reproduce?
Bumping to beta2.  Yell if you disagree.
blocking2.0: beta1+ → beta2+
Keywords: relnote
Assignee: nobody → jmuizelaar
Jeff: we need you to confirm if this is D3D9, please. Moving to betaN, but we'll likely want to pull it in if it's HW acceleration related.
blocking2.0: beta2+ → betaN+
Whiteboard: [needs jrmuizel's input]
(Reporter)

Comment 14

7 years ago
no more crash with Mozilla/5.0 (Windows; Windows NT 5.1; en-US; rv:2.0b2pre) Gecko/20100719 Minefield/4.0b2pre

and I got full screen with Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b2pre) Gecko/20100720 Minefield/4.0b2pre

related?
Bug 574778 - Enabling Full Screen Video is broken

Comment 15

7 years ago
Confirming crash is gone with 20100720 Minefield, still crashed with Nightly before that.
However, maybe this is wfm now because layers are no longer used atm, at least I can see no message whatsoever in error console when entering fullscreen mode.
(Assignee)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ InternalFindAtom]
You need to log in before you can comment on or make changes to this bug.