random assertion "Should be playing: 'IsPlaying()'" while unloading content/media/test/crashtests/459439-1.html or starting load of content/media/test/crashtests/466607-1.html

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

({assertion, intermittent-failure})

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

I've been tracking which reftests/crashtests cause assertions.  This is the first bug on a low-frequency random assertion that I'm filing.

This assertion has happened during crashtests once in the past 3 days or so.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1273279498.1273280292.23119.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/05/07 17:44:58  


While *unloading* the test content/media/test/crashtests/459439-1.html this build log shows the assertion:
###!!! ASSERTION: Should be playing: 'IsPlaying()', file e:/builds/moz2_slave/mozilla-central-win32-debug/build/content/media/nsBuiltinDecoderStateMachine.cpp, line 353

I'll annotate the manifest as indicating that this test randomly asserts so it won't cause random orange once we turn on assertion checking.
Actually, the frequency of this assertion is a good bit higher than that, but it's just that all the previous times it happened after we started loading content/media/test/crashtests/466607-1.html, but this time it happened just before.
Summary: random assertion "Should be playing: 'IsPlaying()'" while unloading content/media/test/crashtests/459439-1.html → random assertion "Should be playing: 'IsPlaying()'" while unloading content/media/test/crashtests/459439-1.html or starting load of content/media/test/crashtests/466607-1.html
And it happens only on Windows.
Just happened during content/media/test/crashtests/493915-1.html once, on Windows.
Thas also showed up on 466945-1.html, twice on 64-bit Linux and once on Windows (out of all tinderbox runs in the past two weeks or so).
Blocks: 569108
Downgraded from assertion to warning:
http://hg.mozilla.org/mozilla-central/rev/51fef780d71a
Duplicate of this bug: 567594
Duplicate of this bug: 569105
Blocks: 438871
Whiteboard: [orange]
Mass marking whiteboard:[orange] bugs WFM (to clean up TBPL bug suggestions) that:
* Haven't changed in > 6months
* Whose whiteboard contains none of the strings: {disabled,marked,random,fuzzy,todo,fails,failing,annotated,leave open,time-bomb}
* Passed a (quick) manual inspection of bug summary/whiteboard to ensure they weren't a false positive.

I've also gone through and searched for cases where the whiteboard wasn't labelled correctly after test disabling, by using attachment description & basic comment searches. However if the test for which this bug was about has in fact been disabled/annotated/..., please accept my apologies & reopen/mark the whiteboard appropriately so this doesn't get re-closed in the future (and please ping me via IRC or email so I can try to tweak the saved searches to avoid more edge cases).

Sorry for the spam! Filter on: #FFA500
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.